Bug 91082 - Dependency problem with the subversion package
Dependency problem with the subversion package
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: subversion (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-17 11:15 EDT by Ed Solis
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-18 15:47:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Solis 2003-05-17 11:15:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
There seems to be a dependency problem with the subversion-0.20.1-6 package.

subversion-0.20.1-6 package requires, among other things, the following:
1. libdb-4.0.so (provided by db4-4.0.14-20)
2. libaprutil-0.so.0 (provided by apr-util-0.9.3-5)

apr-util-0.9.3-5 package requires, among other things, the following:
1. libdb-4.1.so (provided by db4-4.1.25-1)

Unfortunately, the db4-4.1.25-1 package does not provide libdb-4.0.so which the
subversion package I wanted to install in the first place requires.

Summary:

To install subversion-0.20.1-6 requires, among other things, the installation of
apr-util-0.9.3-5 which, in turn, requires among other things, the installation
of db4-4.1.25-1. Unfortunately db4-4.1.25-1 does not provide libdb-4.0.so which
subversion also requires.


Version-Release number of selected component (if applicable):
subversion-0.20.1-6

How reproducible:
Always

Steps to Reproduce:
1. Install the subversion, apr-util, and db4 package
2.
3.
    

Actual Results:  Failed dependency

Expected Results:  Successful installation

Additional info:
Comment 1 Joe Orton 2003-05-18 15:47:03 EDT
To upgrade to db4-4.1.25-1 you need to install compat-db-4.0.14-2 in a same "rpm
-U" invocation, i.e.

  rpm -Uvh db4-4.1.25-1.i386.rpm compat-db-4.0.14-2.i386.rpm

The most recent build of subversion (0.22.2-1) doesn't depend on libdb-4.0.so
any more, FWIW.

Note You need to log in before you can comment on or make changes to this bug.