Bug 91105 - Installer crashed - non-Linux partition
Installer crashed - non-Linux partition
Status: CLOSED DUPLICATE of bug 124843
Product: Red Hat Linux
Classification: Retired
Component: parted (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
none
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-18 11:31 EDT by Thomas E. Dickey
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:53:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
trace from failed install (90.78 KB, text/plain)
2003-05-26 10:29 EDT, Thomas E. Dickey
no flags Details

  None (edit)
Description Thomas E. Dickey 2003-05-18 11:31:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16 i686)

Description of problem:
After selecting "/" partition (/dev/hda14), the install script popped
up a window stating that it could not obtain characteristics for
/dev/hdb3 (which happens to be OpenBSD).  I clicked on "Ignore",
and got a subsequent popup offering the opportunity to "Debug", or
"Cancel" (citing an exception raised in a python script).
Cancelling of course aborts the install.

I tried this twice, don't have a spare machine to waste, so I
installed Slackware 9.0, which works nicely.  It would be nice
to review Redhat 9.0 (maybe).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. see above	
2.
3.
    

Actual Results:  install was aborted.

Expected Results:  unknown partition type should have been ignored, as
requested.

Additional info:
Comment 1 Jeremy Katz 2003-05-25 13:55:22 EDT
Can you provide the exception?
Comment 2 Thomas E. Dickey 2003-05-25 14:33:50 EDT
You're talking about the trace it offered to write to a floppy?No - Friday's are bad for installs, and I was looking for an early
finish.  I'm considering trying the install (on a different partition)
tomorrow morning.  Unless there's some interaction with the partition
numbers (both are on the first drive, while the problem was against
the second), I'd expect to see the same issue there.
Is there any information that I should record that would not be in
that trace?
Comment 3 Jeremy Katz 2003-05-25 15:07:36 EDT
The backtrace usually has everything needed.   Without it, it's hard to say what
happened.
Comment 4 Thomas E. Dickey 2003-05-26 10:29:09 EDT
Created attachment 91970 [details]
trace from failed install

I setup a test using the same configuration as before,
same result.  (Just to be different, I did try "Cancel"
on the first dialog rather than "Ignore", but it made
no difference).
Comment 5 Jeremy Katz 2004-06-25 15:18:51 EDT
Does this happen with newer Fedora releases?
Comment 6 Thomas E. Dickey 2004-06-25 15:51:14 EDT
I don't know (the hardware is no longer a test-machine).
Comment 7 Jeremy Katz 2004-06-25 15:58:45 EDT

*** This bug has been marked as a duplicate of 124843 ***
Comment 8 Red Hat Bugzilla 2006-02-21 13:53:08 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.