Bug 91124 - Upgrade from RH 7.2 to 9.0 failed with "unhandled error"
Upgrade from RH 7.2 to 9.0 failed with "unhandled error"
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-18 23:44 EDT by steve
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 10:51:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description steve 2003-05-18 23:44:14 EDT
Description of problem:
Upgrade from RH 7.2 to 9.0 failed on post installation unhandled error.

"An unhandled exception has occurred.  THis is most likely a bug.  Please copy 
the full text ...

Traceback (most recent call list);
File "/usr/lib/anaconda/gui.py", line 936 in handleRenderCallback 
self.currentWindow.renderCallback()
File "/usr/lib/anaconda/iw/progress_gui.py" line 155 in renderCallback 
self.intf.icw.nextClicked()
File "/usr/lib/anaconda/gui.py" line 761 in nextClicked self.dispatch.gotoNext()
File "/usr/lib/anaconda/dispatch.py" line 157 in gotoNext self.moveStep0
File"/usr/lib/anaconda/dispatch.py" line 225 in moveStep rc = apply(func, 
self.bindArgs(args))
File"/usr/lib/anaconda/bootloader.py" line 118 in write Bootloader 
justConfigFile, intf)
File "/usr/lib/booty/bootloaderInfo.py" line 1029 in write justConfig | 
(self.useGrubVal))
File"/usr/lib/booty/bootloaderInfo.py" line 910 in writeLilo config.delEntry
("default")
File "/usr/lib/booty/lilo.py" line 120 in delEntry del self.items[item]
File "/usr/lib/booty/lilo.py" line 38 in__delitem__ del self data[key]
KeyError:default

install exited abnormally
----------------
When system tries to reboot I get the message "LIWrong loader, giving up..." 
and hangs - system is unusable

Tried to upgrade 

Version-Release number of selected component (if applicable):
RH 9.0

How reproducible:
Can't reproduce without loosing data

Steps to Reproduce:
1.Tried to upgrade again - already at 9.0
2.Loader not written because no kernel pkg loaded - selected kernel pkg in 
custom upgrade option
3.Tried "Create new boot loader config"  (originally default to "Update boot 
loader config"
    
Actual results:

 "LIWrong loader, giving up..." and hangs - system is unusable




Expected results:  Boot loader upgraded.


Additional info: None
Comment 1 Jeremy Katz 2003-05-19 14:57:53 EDT
Fixed in CVS
Comment 2 Brent Fox 2003-05-25 10:51:18 EDT
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.

Note You need to log in before you can comment on or make changes to this bug.