Bug 91129 - redhat-config-printer*-0.6.53-1 : Can't locate Foomatic/Defaults.pm
Summary: redhat-config-printer*-0.6.53-1 : Can't locate Foomatic/Defaults.pm
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: foomatic   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-19 07:04 UTC by Olivier Baudron
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-23 21:29:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Olivier Baudron 2003-05-19 07:04:56 UTC
# redhat-config-printer
Can't locate Foomatic/Defaults.pm in @INC (@INC contains:
/usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl
/usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 .) at
/usr/bin/foomatic-configure line 13.

Comment 1 Olivier Baudron 2003-05-19 08:00:01 UTC
Ok, the problem is that foomatic-3.0.0-1 should require perl>=5.8.1 (instead of
perl>=5.6.1), since it installs perl modules in /usr/lib/perl5/vendor_perl/5.8.1

An upgrade to perl-5.8.1-0.pre19439.0 indeed fixes the problem.

Comment 2 Tim Waugh 2003-05-23 21:29:54 UTC
Actually perl-5.8.0-xxx should be used, and foomatic-3.0.0-4.


Note You need to log in before you can comment on or make changes to this bug.