Bug 91135 - xinetd-2.3.11-1.7x times service(s) broken
xinetd-2.3.11-1.7x times service(s) broken
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: xinetd (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-19 04:37 EDT by Frank Elsner
Modified: 2014-08-31 19:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 16:26:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Elsner 2003-05-19 04:37:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.20 i686)

Description of problem:
After upgrading "xinetd" on RH 7.3 system to version 2.3.11 
I've problems with the former working service "time-dgram".

In /var/log/messages these messages show up

xinetd[3617]: libwrap refused connection to time-dgram from 130.149.128.4
May 16 13:45:52 mailbox xinetd[3617]: FAIL: time-dgram libwrap
from=130.149.128.4

The - unchanged - file /etc/hosts/allow contains
                       ----------------
time-dgram: ALL

File /etc/xinetd.d/time-udp contains
     ----------------------
service time
{
        type            = INTERNAL UNLISTED
        id              = time-dgram
        socket_type     = dgram
        protocol        = udp
        user            = root
        wait            = yes
        disable         = no
        port            = 37
} 

Where ist the problem ?

Kind regards, Frank Elsner


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Use xinetd-2.3.11
2. Activate time-dgram
3.
    

Additional info:
Comment 1 Jay Fenlason 2003-08-11 13:18:18 EDT
It looks like xinetd changed how it chooses the service name to look up in 
/etc/hosts.{deny,allow}, and I didn't notice when I was building the errata 
packages.  Instead of looking for "time-dgram" in /etc/hosts.allow, it's now 
looking for "time". 
 
I've just built xinetd-2.3.12-1.10.0 in Raw Hide.  It includes a 
slightly-post-2.3.12 patch that a) defines in the documentation how xinetd 
chooses the service name to look up in /etc/hosts.{deny,allow} and b) allows 
you to override the default with an explicit "libwrap" paramater. 
 
The Raw Hide binary probably won't work on a Red Hat Linux 7.3 system, but you 
can certainly download the SRPM and rpmbuild --rebuild it. 
 
Does this fix the problem for you? 
Comment 2 Bill Nottingham 2006-08-04 16:26:59 EDT
Red Hat Linux and Red Hat Powertools are currently no longer supported by Red
Hat, Inc. In an effort to clean up bugzilla, we are closing all bugs in MODIFIED
state for these products.

However, we do want to make sure that nothing important slips through the
cracks. If, in fact, these issues are not resolved in a current Fedora Core
Release (such as Fedora Core 5), please open a new issues stating so. Thanks.

Note You need to log in before you can comment on or make changes to this bug.