Bug 912925 - [abrt] asymptote-2.21-3.fc18: exit: Process /usr/bin/asy was killed by signal 6 (SIGABRT)
Summary: [abrt] asymptote-2.21-3.fc18: exit: Process /usr/bin/asy was killed by signal...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: asymptote
Version: 18
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:9d5813531a4a11d971562c60f2c...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-20 02:03 UTC by Horst H. von Brand
Modified: 2013-12-19 07:18 UTC (History)
2 users (show)

Fixed In Version: asymptote-2.24-2.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-19 07:16:36 UTC


Attachments (Terms of Use)
File: backtrace (24.05 KB, text/plain)
2013-02-20 02:03 UTC, Horst H. von Brand
no flags Details
File: cgroup (131 bytes, text/plain)
2013-02-20 02:03 UTC, Horst H. von Brand
no flags Details
File: core_backtrace (5.79 KB, text/plain)
2013-02-20 02:03 UTC, Horst H. von Brand
no flags Details
File: dso_list (3.48 KB, text/plain)
2013-02-20 02:03 UTC, Horst H. von Brand
no flags Details
File: environ (4.25 KB, text/plain)
2013-02-20 02:03 UTC, Horst H. von Brand
no flags Details
File: limits (1.29 KB, text/plain)
2013-02-20 02:03 UTC, Horst H. von Brand
no flags Details
File: maps (19.15 KB, text/plain)
2013-02-20 02:03 UTC, Horst H. von Brand
no flags Details
File: open_fds (145 bytes, text/plain)
2013-02-20 02:03 UTC, Horst H. von Brand
no flags Details
File: proc_pid_status (922 bytes, text/plain)
2013-02-20 02:03 UTC, Horst H. von Brand
no flags Details
File: var_log_messages (213 bytes, text/plain)
2013-02-20 02:03 UTC, Horst H. von Brand
no flags Details

Description Horst H. von Brand 2013-02-20 02:03:00 UTC
Description of problem:
Processing a 3D image:

import three;
import texcolors;

settings.render = 4;

unitsize(1.5cm);
currentprojection = perspective((5, 4, 2) * 2);


real r = 0.16;

void queso(bool bipartite)
{
  int i, j, k;
  surface node = scale(r, r, r) * unitsphere;

  for(i = 0; i < 3; ++i) {
    for(j = 0; j < 3; ++j) {
      draw((i, j, 0) -- (i, j, 2), Black + 1.7);
      draw((i, 0, j) -- (i, 2, j), Black + 1.7);
      draw((0, i, j) -- (2, i, j), Black + 1.7);
    }
  }
  for(i = 0; i < 3; ++i) {
    for(j = 0; j < 3; ++j) {
      for(k = 0; k < 3; ++k) {
        draw(shift(i, j, k) * node,
             bipartite ?
               ((i + j + k) % 2 == 0 ? Blue : Red)
               : YellowOrange);
      }
    }
  }
}

queso(false);

shipout("cubo-queso");

currentpicture = new picture;
unitsize(1.5cm);
currentprojection = perspective((5, 4, 2) * 2);

queso(true);

shipout("cubo-queso-bipartito");

Version-Release number of selected component:
asymptote-2.21-3.fc18

Additional info:
backtrace_rating: 4
cmdline:        asy -tex pdflatex queso-3D.asy
crash_function: exit
executable:     /usr/bin/asy
kernel:         3.6.9-4.fc18.x86_64
remote_result:  NOTFOUND
uid:            1000

Truncated backtrace:
Thread no. 1 (5 frames)
 #43 exit at exit.c:99
 #44 asymain at main.cc:153
 #45 GC_inner_start_routine at pthread_start.c:56
 #46 GC_call_with_stack_base at misc.c:1556
 #48 __getauxval at getauxval.c:32

Comment 1 Horst H. von Brand 2013-02-20 02:03:07 UTC
Created attachment 699776 [details]
File: backtrace

Comment 2 Horst H. von Brand 2013-02-20 02:03:10 UTC
Created attachment 699777 [details]
File: cgroup

Comment 3 Horst H. von Brand 2013-02-20 02:03:12 UTC
Created attachment 699778 [details]
File: core_backtrace

Comment 4 Horst H. von Brand 2013-02-20 02:03:14 UTC
Created attachment 699779 [details]
File: dso_list

Comment 5 Horst H. von Brand 2013-02-20 02:03:16 UTC
Created attachment 699780 [details]
File: environ

Comment 6 Horst H. von Brand 2013-02-20 02:03:18 UTC
Created attachment 699781 [details]
File: limits

Comment 7 Horst H. von Brand 2013-02-20 02:03:21 UTC
Created attachment 699782 [details]
File: maps

Comment 8 Horst H. von Brand 2013-02-20 02:03:23 UTC
Created attachment 699783 [details]
File: open_fds

Comment 9 Horst H. von Brand 2013-02-20 02:03:27 UTC
Created attachment 699784 [details]
File: proc_pid_status

Comment 10 Horst H. von Brand 2013-02-20 02:03:29 UTC
Created attachment 699785 [details]
File: var_log_messages

Comment 11 Michael Jørgensen 2013-12-07 21:37:21 UTC
This is reproducible.

I run the command "asy latexusage-2.asy", and the process coredumps.

The file latexusage-2.asy contains:
if(!settings.multipleView) settings.batchView=false;
settings.inlinetex=true;
deletepreamble();
defaultfilename="latexusage-2";
if(settings.render < 0) settings.render=4;
settings.outformat="";
settings.inlineimage=true;
settings.embed=true;
settings.toolbar=false;
viewportmargin=(2,2);

// Global Asymptote definitions can be put here.
import three;
usepackage("bm");
texpreamble("\def\V#1{\bm{#1}}");
// One can globally override the default toolbar settings here:
// settings.toolbar=true;


currentprojection=orthographic(5,4,2);
draw(unitcube,blue);
label("$V-E+F=2$",(0,1,0.5),3Y,blue+fontsize(17pt));
size(0,113.81102pt,keepAspect=true);
viewportsize=(390.0pt,0);


reporter:       libreport-2.1.9
backtrace_rating: 4
cmdline:        asy latexusage-2.asy
crash_function: exit
executable:     /usr/bin/asy
kernel:         3.11.9-100.fc18.x86_64
package:        asymptote-2.21-3.fc18
reason:         Process /usr/bin/asy was killed by signal 6 (SIGABRT)
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 12 Tom "spot" Callaway 2013-12-09 15:32:14 UTC
Looks like these issues are fixed in 2.24, please test when the update lands.

Comment 13 Fedora Update System 2013-12-09 16:46:14 UTC
asymptote-2.24-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/asymptote-2.24-2.fc18

Comment 14 Fedora Update System 2013-12-09 16:46:32 UTC
asymptote-2.24-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/asymptote-2.24-2.fc19

Comment 15 Fedora Update System 2013-12-10 06:11:01 UTC
Package asymptote-2.24-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing asymptote-2.24-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23078/asymptote-2.24-2.fc19
then log in and leave karma (feedback).

Comment 16 Fedora Update System 2013-12-10 06:11:15 UTC
Package asymptote-2.24-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing asymptote-2.24-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23070/asymptote-2.24-2.fc18
then log in and leave karma (feedback).

Comment 17 Fedora Update System 2013-12-19 07:16:36 UTC
asymptote-2.24-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2013-12-19 07:18:29 UTC
asymptote-2.24-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.