Bug 91316 - tar: /dev/st0: Warning: Cannot close: Input/output error
tar: /dev/st0: Warning: Cannot close: Input/output error
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: tar (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Ben Levenson
:
: 91318 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-21 09:21 EDT by Stanley
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-21 13:05:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stanley 2003-05-21 09:21:28 EDT
Description of problem:
When i use my DDS-4 of IBM, i get some problems.
____________________________________________________________
#mt -f /dev/st0 status

 SCSI 2 TAPE DRIVE:
 File Number - 0, block number=0, partition = 0.
 Tape block size 512 bytes. Density code 0x26 (DDS-4 or QIC-4GB).
 Soft Error count since last status=0
 General Status bits on (41010000):
 BOT ONLINE IM_REP_EN

#mt -t /dev/st0 rewind

#tar -c -v -V "Fullbackup" -f /dev/st0 -g /var/adm/backup/Dir etc/ home/
 tar: /dev/st0: Warning: Cannot close: Input/output error
_____________________________________________________________________

then i don't have my backup.
What should i do?

Version-Release number of selected component (if applicable):

my linux is Linux Implant  2.4.18-3smp #1 SMP Thu Apr 18 07:27:31EDT 2002 i686
and may mt is mt-st v. 0.7

How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
Comment 1 Ngo Than 2003-05-21 10:06:13 EDT
*** Bug 91318 has been marked as a duplicate of this bug. ***
Comment 2 Ngo Than 2003-05-21 12:31:37 EDT
it looks like a bug in tar.
Jeff, i don't have hardware for testing.
Comment 3 Jeff Johnson 2003-05-21 13:05:54 EDT
A EIO (i.e. "Input/Output error") from a tape device
is invariably either a media (usually) or a hardware
(occaisionally) problem.

An EIO on tape rewind is often misleading, as the real media
error was someplace else, but, because of buffering, is only
reported at close (or at rewind when final tape marks force a buffer
flush).

Watch out for a false EIO indication when trying to
read a tape produced at a different density.

The density can be selected either through hardware, or
by opening magically named tape devices. What can be confusing
is competing attempts at selecting density, where the
manually selected density is changed when a magically named
tape device selects (and overrides) a different density.

Convince yourself that it's not a hardware error by trying to
write and read back a small set of files from a new
tape.

Convince yourself that it's not a media error by attempting
to read from a different tape drive (if available).

Reopen this bug if you really think it's a software problem,
as I believe it's a media problem.
Comment 4 Stanley 2003-05-21 13:10:11 EDT
i don't think!!!!
Comment 5 Stanley 2003-05-21 14:07:49 EDT
Thanks gay.
But
I tested with another machines and O.S. My medias are new and are in perfect state. 
I tested too.

I saw something about of "General Status bits on (41010000):" mable i have
change it. But i don't known. I think. it my use with command "#dd if=/dev/st0 ..." 
What are you think about it???
___________________________________________________________
#mt -f /dev/st0 status

 SCSI 2 TAPE DRIVE:
 File Number - 0, block number=0, partition = 0.
 Tape block size 512 bytes. Density code 0x26 (DDS-4 or QIC-4GB).
 Soft Error count since last status=0
>> General Status bits on (41010000):<<
 BOT ONLINE IM_REP_EN
________________________________________________________________________
Comment 6 Stanley 2003-05-21 14:23:28 EDT
sorry about "GAY". i'm from Brazil, I write English very Badly. I wanted have
writen GUY. PLEASE SORRY.
Comment 7 Stanley 2003-05-22 08:52:42 EDT
Hi,
I have looked the cable of my SCSI, the pin of controler was fledged.
sorry so much!!!!
Thanks a lot.
We resolved that problem!!!!

Note You need to log in before you can comment on or make changes to this bug.