Bug 91359 - cannot print with hp 3420 configured with printconf
cannot print with hp 3420 configured with printconf
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: cups (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-21 16:47 EDT by Marcin
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-09 04:50:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
messages takaen for /var/log/cups/error_log (full debug is set) (11.12 KB, text/plain)
2003-05-21 16:50 EDT, Marcin
no flags Details
output of printconf-tui --Xexport (1.93 KB, text/plain)
2003-05-22 13:36 EDT, Marcin
no flags Details
/var/log/cups/error_log with full debug turned on, when trying to print test page (32.17 KB, text/plain)
2003-05-24 16:13 EDT, Marcin
no flags Details

  None (edit)
Description Marcin 2003-05-21 16:47:44 EDT
Description of problem:


Version-Release number of selected component (if applicable):
1.1.17-13

How reproducible
always

Steps to Reproduce:
1.add a printer in printconf
2.select hp 3420 (hpijs driver)
3.send a cups test page
    
Actual results:
no page at all is printed, the printconf gui says Media Tray Empty!

Expected results
a page should be printed
Additional info:
Comment 1 Marcin 2003-05-21 16:50:07 EDT
Created attachment 91866 [details]
messages takaen for /var/log/cups/error_log (full debug is set)
Comment 2 Tim Waugh 2003-05-22 09:36:37 EDT
The 'Media Tray Empty!' message is harmless, and isn't the cause of this
problem. (It is mistaken, and this bug has since been fixed.)

Please attach the output of 'printconf-tui --Xexport'.  Thanks.
Comment 3 Marcin 2003-05-22 13:36:13 EDT
Created attachment 91901 [details]
output of printconf-tui --Xexport
Comment 4 Tim Waugh 2003-05-22 13:53:35 EDT
Please fetch this file:

ftp://people.redhat.com/twaugh/tmp/hp3420.bz2

Uncompress it like this:

bunzip2 hp3420.bz2

Then send it to the printer like this (as root):

cat hp3420 > /dev/usb/lp0

Does that give any better results?  This is the output from a newer version of
the printer driver (hpijs) for that model.
Comment 5 Marcin 2003-05-22 14:23:34 EDT
after  
[root@164-tor-1 download]# chown root:root hp3420 
[root@164-tor-1 download]# cat hp3420 > /dev/usb/lp0 
a perfect test page was printed, what do I have to upgrade to make it work 
with printconf to all users? 
 
Cheers 
Marcin 
Comment 6 Tim Waugh 2003-05-23 05:21:05 EDT
Just the hpijs package.  The current rawhide (untested) version, which
hp3420.bz2 was generated by, is hpijs-1.4-2.  You can get it from
ftp://ftp.redhat.com/pub/redhat/linux/rawhide.

You could try upgrading that package and seeing if you can print afterwards; if
not, obviously the problem is elsewhere.
Comment 7 Marcin 2003-05-24 08:19:56 EDT
Hi,

I installed hpijs 1.4 from rawhide. Now I'm getting the following message from
/var/log/messages when trying to print the cups test page
May 24 14:09:11 164-tor-1 hpijs: unable to read client data err=-2

Can you give me any hints where elsewhere to look, or what logs to take?

Cheers
Marcin
Comment 8 Tim Waugh 2003-05-24 14:21:08 EDT
Perhaps you also need to upgrade ghostscript.

You could set 'LogLevel debug' in /etc/cups/cupsd.conf and look in
/var/log/cups/error_log for more logs.
Comment 9 Marcin 2003-05-24 16:13:32 EDT
Created attachment 91943 [details]
/var/log/cups/error_log with full debug turned on, when trying to print test page
Comment 10 Tim Waugh 2003-05-24 18:27:45 EDT
Did you also try upgrading ghostscript?
Comment 11 Marcin 2003-06-08 16:42:17 EDT
hi,

After upgrading ghostscript it works perfectly
thanks for your help
cheers
Marcin

Note You need to log in before you can comment on or make changes to this bug.