Bug 91402 - Redhat Kernel 2.4.20-13.9 breaks SiS 7012 Sound Card (AC 97)
Redhat Kernel 2.4.20-13.9 breaks SiS 7012 Sound Card (AC 97)
Status: CLOSED DUPLICATE of bug 92043
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-22 08:16 EDT by Chris Fuhrman
Modified: 2007-04-18 12:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:53:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Fuhrman 2003-05-22 08:16:40 EDT
Description of problem:

Upgrading to Redhat Kernel 2.4.20-13.9 breaks SiS 7012 Sound Card (AC 97 Sound)

Version-Release number of selected component (if applicable):

kernel-2.4.20-13.9

How reproducible:

Always

Steps to Reproduce:
1. Upgrade to kernel-2.4.20-13.9
2.
3.
    
Actual results:

Sound no longer works.

Expected results:

Sound should be working (worked on previous kernels)

Additional info:

From /var/log/messages

messages:May 21 17:30:07 icestorm kernel: Intel 810 + AC97 Audio, version 0.24,
11:35:11 May 12 2003
messages:May 21 17:30:07 icestorm kernel: i810_audio: Audio Controller supports
2 channels.
messages:May 21 17:30:07 icestorm kernel: i810_audio: Defaulting to base 2
channel mode.
messages:May 21 17:30:07 icestorm kernel: i810_audio: Resetting connection 0
messages:May 21 17:30:07 icestorm kernel: i810_audio: only 48Khz playback available.
messages:May 21 17:30:07 icestorm kernel: i810_audio: AC'97 codec 0 Unable to
map surround DAC's (or DAC's not present), total channels = 2

Also.  I previously had Redhat 7.3 on this machine.  Upgrading to 2.4.20 under
7.3 also broke sound support so it's a problem inherant with that kernel. 
Rebooting with a previous kernel fixes the problem.  I do not know if this
kernel update affects other Redhat releases.
Comment 1 Clifford Snow 2003-05-23 15:18:52 EDT
I also have the same problem on a athlon Redhat 9.0 installation.  After
upgrading to 2.4.20-13.9, the SiS 7012 Sound Card stopped functioning.  
Comment 2 Bill Woodward 2003-05-23 23:03:31 EDT
I see this too, on RedHat 9 with the 2.4.20-13.9 kernel, by onboard AC 97 sound
no longer configures.  I backed down to the original RH9 kernel (2.4.20-8), and
it works fine.
Comment 3 Chris Fuhrman 2003-06-06 07:41:46 EDT
Upgrading to kernel-2.4.20-18.9 does not fix problem.
Comment 4 Alan Cox 2003-06-08 09:12:07 EDT

*** This bug has been marked as a duplicate of 92043 ***
Comment 5 Red Hat Bugzilla 2006-02-21 13:53:12 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.