Bug 91475 - up2date/rhn_applet using wrong DNS servers for resolution
up2date/rhn_applet using wrong DNS servers for resolution
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Clifford Perry
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-22 18:44 EDT by Jason Dixon
Modified: 2012-06-20 12:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 12:11:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Dixon 2003-05-22 18:44:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
I'm running RH9 on a laptop with different "profiles".  My RHN demo account was
originally registered on my office network where the DNS resolvers are in the
10.x.x.x address space.  However, my home network uses my ISP's resolvers on
public address space.  I've noticed that rhnsd/rhn_applet/up2date cannot
correctly resolve www.rhns.redhat.com (via tcpdump), as it's trying to use the
10.x.x.x nameservers.

I tried to "reset" my settings by restarting rhnsd, no luck.  Tried to find the
cached DNS information by performing a recursive grep on /etc and /var, but
couldn't find anything.

Version-Release number of selected component (if applicable):
up2date-3.1.23-1, rhn-applet-2.0.9-0.9.0.1

How reproducible:
Always

Steps to Reproduce:
1. Run rhn_applet
2.
3.
    

Actual Results:  Unable to connect to RHN.

Expected Results:  Connect to RHN.

Additional info:
Comment 4 Jiri Pallich 2012-06-20 12:11:53 EDT
Thank you for submitting this issue for consideration in Red Hat Enterprise Linux. The release for which you requested us to review is now End of Life. 
Please See https://access.redhat.com/support/policy/updates/errata/

If you would like Red Hat to re-consider your feature request for an active release, please re-open the request via appropriate support channels and provide additional supporting details about the importance of this issue.

Note You need to log in before you can comment on or make changes to this bug.