Bug 91504 - produces errors when using cutoff for certain partitions
produces errors when using cutoff for certain partitions
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: diskcheck (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-23 10:04 EDT by Brian Johnson
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version: 1.4-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-23 11:57:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my config file (878 bytes, text/plain)
2003-05-23 10:47 EDT, Brian Johnson
no flags Details

  None (edit)
Description Brian Johnson 2003-05-23 10:04:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
It was working fine but I wanted to increase the cutoff for a couple of
partitions and now I get errors:

/etc/cron.hourly/diskcheck:

Traceback (most recent call last):
File "/etc/cron.hourly/diskcheck", line 298, in ?
if (nPct < long(cutoff[volume])): continue
ValueError: invalid literal for long(): 95 # /var 

I changed the commented cutoff lines in the default diskcheck.conf to:
cutoff['/dev/hda4'] = 95  
cutoff['/dev/hdd4'] = 95 



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. see description please
2.
3.
    

Additional info:
Comment 1 Harald Hoyer 2003-05-23 10:09:16 EDT
please attach your diskcheck.conf
Comment 2 Brian Johnson 2003-05-23 10:47:18 EDT
Created attachment 91918 [details]
my config file
Comment 3 Brian Johnson 2003-05-23 11:09:46 EDT
The problem is the comments after (included on) the cutoff line

Now it works as expected

Comment 4 Harald Hoyer 2003-05-23 11:57:14 EDT
yeah, I fixed that comment problem... should be fixed in diskcheck >= 1.4-3

Note You need to log in before you can comment on or make changes to this bug.