Bug 91565 - RH 9.0 Kernel updates are installed incorrectly via the RPMs or the RHN instructions
RH 9.0 Kernel updates are installed incorrectly via the RPMs or the RHN instr...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Clifford Perry
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-24 10:04 EDT by Justin Churchey
Modified: 2010-04-23 12:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-23 12:48:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Bad GRUB config file generated by up2date (or rpm) (821 bytes, text/plain)
2003-05-24 10:06 EDT, Justin Churchey
no flags Details
Corrected GRUB Config (1000 bytes, text/plain)
2003-05-24 10:25 EDT, Justin Churchey
no flags Details
Bad GRUB file generated after 2.4.20-18.0 update (970 bytes, text/plain)
2003-06-09 09:54 EDT, Justin Churchey
no flags Details

  None (edit)
Description Justin Churchey 2003-05-24 10:04:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030410

Description of problem:
This has happened before, but I dismissed it earlier as an unrelated problem and
a problem w/ my own configuration.  However,  after installing the latest kernel
release from RHN (kernel-2.4.20-13.9) for my i686, when trying to boot this
kernel using grub, I get the following kernel panic:


VFS: Cannot open root device "LABEL=/" or 00:00
Please append a correct "root=" boot option
Kernel panic : VFS: Unable to mount root fs on 00:00

Because this has happened before, I know that the grub.conf in my seperate /boot
partition was written wrong by the installation rpm downloaded from RHN.  Either
the file was corrupted a second time, or the rpm was built wrong.  Then again,
it could be the RPM program itself. Either way it's very important.  I am
posting a copy of my bad grub.conf file, and I will upload the corrected one at
a later time.

Version-Release number of selected component (if applicable):
rpm-4.2-0.69, up2date-3.1.23-1

How reproducible:
Always

Steps to Reproduce:
1.Download and install the latest kernel update from RHN using up2date
2.Reboot the computer, and use GRUB to boot RH w/ recently installed kernel
3.
    

Actual Results:  Receiver Kernel panic:

VFS: Cannot open root device "LABEL=/" or 00:00
Please append a correct "root=" boot option
Kernel panic : VFS: Unable to mount root fs on 00:00

Expected Results:  Boot properly

Additional info:

Workaround is possible just by fixing the grub.conf file, but I feel that this
could discourage any inexperienced person trying to learn linux from pursuing it
farther.  This problem really needs to be alleviated.
Comment 1 Justin Churchey 2003-05-24 10:06:32 EDT
Created attachment 91939 [details]
Bad GRUB config file generated by up2date (or rpm)
Comment 2 Justin Churchey 2003-05-24 10:25:05 EDT
Created attachment 91940 [details]
Corrected GRUB Config

Changes to the file, have been commented.
Comment 3 Justin Churchey 2003-06-09 09:51:23 EDT
Download the latest kernel from RH (2.4.20-18.9).  When rpm installed, it made
the same error as usual, mixing up the LABEL=/ option and the root= option. 
This is a fairly reoccuring and important but, and I am not sure why I am not
getting a response.
Comment 4 Justin Churchey 2003-06-09 09:54:15 EDT
Created attachment 92275 [details]
Bad GRUB file generated after 2.4.20-18.0 update

The error is consistent and needs to be fixed.
Comment 5 Justin Churchey 2005-10-05 11:21:45 EDT
Why is this being assigned now?  It's been over two years.
Comment 7 RHEL Product and Program Management 2010-04-23 12:48:03 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.