Bug 915734 - Tabular report links should open sub reports with 'equal to' rather than 'contains'
Tabular report links should open sub reports with 'equal to' rather than 'con...
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Reporting/Charting (Show other bugs)
4.2
Unspecified Unspecified
medium Severity medium (vote)
: ---
: ---
Assigned To: Simon Green
Matt Tyson
:
Depends On:
Blocks: 1062518
  Show dependency treegraph
 
Reported: 2013-02-26 07:04 EST by Itamar Heim
Modified: 2014-10-12 18:49 EDT (History)
3 users (show)

See Also:
Fixed In Version: 4.4.1013
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-03 20:13:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot for comment1 (107.22 KB, image/png)
2013-06-04 23:09 EDT, wangjing
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 926117 None None None Never

  None (edit)
Description Itamar Heim 2013-02-26 07:04:10 EST
Description of problem:
when doing a tabular report, i may get something like the following when specifying the whiteboard column:
a     5
a b   3
a,b   4
b     2

when clicking any of the links in the report, the generated query uses the format of "contains a', instead of 'equal a'

this means i will get results for both 'a', 'a b', 'a,b' in the generated report.
also, if i chose the 'a,b' link, i will get all results, since they all contain either 'a' or 'b'.


Version-Release number of selected component (if applicable):
version 4.2.5-7.1

How reproducible:
100%


please change generated query to use 'equals' rather than 'contains'.
better if can also be case sensitive, since the tabular report is case sensitive to 'a' and 'A', but there is no way to make a report for equals (case sensitive), only for contains, which misses the point.

Thanks,
   Itamar
Comment 1 wangjing 2013-06-04 23:07:35 EDT
tested on QE test env version 4.4-3.3
steps:
1. add 'a' in whiteboard of bug1, add 'b' in whiteboard of bug2, add 'a b' in whiteboard of bug3, add 'a,b' in whiteboard of bug4, all bugs are from product bugzilla.
2. click 'Reports->Tabular reports->set 'whiteboard' as 'Vertical Axis', set 'Status' as 'Horizontal Axis', and select product bugzilla, then click button 'Generate Report'.
3. click the links on the line of whiteboard 'a,b' in the table.

Actual result:
bug4 with 'a,b' in whiteboard was not in the buglist, but bug1 and bug2 were returned by clicking the link '1' in 'Total' column, and bug1 or bug2 was returned by clicking the link '1' in 'NEW' or 'ASSIGNED' column(the link '1' was in column 'NEW' or 'ASSIGNED' depends on bug4's status)

Expected result:
I considered how we should deal with this kind of 'a,b' values in whiteboard, on current version listing it in a separate line, we should make the links in this line all link to the bug4, rather than bug1, bug2.

Additional:
table screenshot attached.
Comment 2 wangjing 2013-06-04 23:09:42 EDT
Created attachment 757036 [details]
screenshot for comment1
Comment 6 Jason McDonald 2014-02-03 20:13:44 EST
This change is now live. If there are any issues, do not reopen this bug.
Instead, you should create a new bug and reference this bug.

Note You need to log in before you can comment on or make changes to this bug.