Bug 91582 - Error: Unable to restore run data (1)
Error: Unable to restore run data (1)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: webalizer (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
http://www.xenobyte.net/usage/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-24 18:09 EDT by Christopher Scott Kindley
Modified: 2013-06-24 11:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-31 04:16:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Scott Kindley 2003-05-24 18:09:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Clean install of Red Hat 9. All packages selected during install on this
development machine. Errata updates applied fully up to Saturday May 24, 2003. I
decided I would not use webalizer so I did rpm -e webalizer. The later decided I
would use it and did up2date webalizer. Webalizer downloaded and installed with
no errors. When visiting the URL www.xenobyte.net/usage/ after the default
install I saw stats as expected. After removing and readding and returning to
that URL there is only two images...no other files or expected output. So I ran
webalizer as root and the output returned was "Error: Unable to restore run data
(1)". So I once again rpm -e webalizer. This time I went in and manually removed
all rpmsave files associated with webalizer and made sure rpm did not leave old
webalizer files around. So I deleted the /var/lib/webalizer dir as well. Again
performed an up2date webalizer and still have the same unexpected results. I can
reproduce this effect on a totally seperate machine as well. The
/etc/webalizer.conf file was not altered in any way.

Version-Release number of selected component (if applicable):
webalizer-2.01_10-11

How reproducible:
Always

Steps to Reproduce:
1.Explained in description.
2. rpm -e webalizer
3. up2date webalizer
4. run webalizer as root    

Actual Results:  Error: Unable to restore run data (1)

Expected Results:  I should have see a webpage when visiting
http://www.xenobyte.net/usage with statistics from the log files. I checked that
logfiles and their paths were correct. They are present and correct path listed
in the default webalizer.conf file.

Additional info:

It also creates errors when run-parts /etc/cron.daily runs from cron.
Specifically the same error I get manually.
Comment 1 Christopher Scott Kindley 2003-05-31 04:16:03 EDT
This is not a bug. I figured it out. When vitual hosts have log file names and
location specified in the httpd.conf file the default /var/log/httpd/access.log
is not written to. That log file is the default log file used in the
/etc/webalizer.conf file. So by setting the correct log file path and name in
/etc/webalizer.conf and re-running webalizer the errors stop and the expected
results, including webalizer outputs occur. Sorry to have wasted everyones time!

Note You need to log in before you can comment on or make changes to this bug.