Bug 91610 - DPI setting only works in millimeters
DPI setting only works in millimeters
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-xfree86 (Show other bugs)
9
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-25 18:55 EDT by J.B. Nicholson-Owens
Modified: 2007-04-18 12:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-28 11:34:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J.B. Nicholson-Owens 2003-05-25 18:55:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20011022
Netscape6/6.2

Description of problem:
redhat-config-xfree86-0.7.3-2 only works if you put in measurements in
millimeters.  The app lets you think it's okay to put in inches, but if you do
the calculated DPI is obviously wrong.

Some apps (OpenOffice.org, most notably) use the screen's DPI values by default
and thus become unusable when the DPI settings are wrong.  So it's important
that the screen's horizontal and vertical DPI are either set correctly or set to
0 (in which case "unknown" is listed by redhat-config-xfree86 and some
acceptable built-in default is used).  Other apps (like the GIMP) use a
reasonable screen DPI by default but let the user switch to the system value. 
For these apps it is not crucial that the DPI be correct, but it would be nicer
if the DPI settings were okay.

This bug might look like bug 90190 but it is different.  That bug refers to the
default setting of redhat-config-xfree86.  This bug refers to what happens when
you use the "inches" setting at all--it doesn't work.

I think the application's conversion from inches to millimeters is broken.

WORKAROUND: Only use the millimeters setting, don't use the inches setting.  Put
your measurements in millimeters, not inches.  If you only have a ruler with
inches, convert to millimeters manually and type in the measurements in
millimeters.  One 1in is approximately 25.4mm.

Version-Release number of selected component (if applicable):
0.7.3-2

How reproducible:
Always

Steps to Reproduce:
1. Start redhat-config-xfree86
2. Put in correct measurements for your display in inches (make sure the app is
set to inches)
3. Read the DPI setting the app calculates and notice how wildly wrong it is
(probably something far higher than it should be).
4. Set the reading to millimeters and put in proper measurements in millimeters.
5. Read the DPI setting and notice how the setting is far more sane.

Actual Results:  Everything works fine.

Expected Results:  Everything should have worked fine even if I used inches.

Additional info:
Comment 1 Mike A. Harris 2003-05-25 20:13:27 EDT
This seems to be the cause of the OpenOffice DPI weirdness.  Adding
jakub to CC so he can close all openoffice bugs as dupes of this one.
Comment 2 Brent Fox 2003-08-28 11:34:51 EDT
The DPI widgets have been removed in cvs head.

Note You need to log in before you can comment on or make changes to this bug.