Bug 91632 - "/etc/rc.d/init.d/named stop" error : app.c:561: unexpected error: isc_app_shutdown() pthread_kill: No such process
"/etc/rc.d/init.d/named stop" error : app.c:561: unexpected error: isc_app_sh...
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-26 09:47 EDT by Donghyun Kim
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-27 10:15:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Donghyun Kim 2003-05-26 09:47:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 
1.0.3705)

Description of problem:
to stop named, run "/etc/rc.d/init.d/named stop"
but, there is still named running
(there is no error with bind-checkconf, bind-checkzone)
and /var/log/messages reports followings

May 26 22:36:23 master named[3779]: app.c:561: unexpected error:
May 26 22:36:23 master named[3779]: isc_app_shutdown() pthread_kill: No such 
process

when named running, "rndc stop" command showed above error
and didn't be killed.

there is one report by another guy to this in USENET.

http://groups.google.co.kr/groups?q=%22isc_app_shutdown()
+pthread_kill:+No+such+process%22&hl=ko&lr=&ie=UTF-8&oe=UTF-
8&newwindow=1&selm=b9d7qs%247sl%241%40atlantis.news.tpi.pl&rnum=1


Version-Release number of selected component (if applicable):
bind-9.2.1-16

How reproducible:
Always

Steps to Reproduce:
1. /etc/rc.d/init.d/named start
2. /etc/rc.d/init.d/named stop
3. tail /var/log/messages
    

Additional info:
Comment 1 Michael Young 2003-05-26 17:35:52 EDT
This could be a known problem in the 2.4.20-8 kernel. Try one of the errata
kernels instead.
Comment 2 Daniel Walsh 2003-05-27 10:15:41 EDT
Please upgrade to the latest kernel errata.  This problem is caused by a kernel
problem.

Dan

Note You need to log in before you can comment on or make changes to this bug.