Bug 91641 - gnupg package %post scriplet and --excludedocs
Summary: gnupg package %post scriplet and --excludedocs
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnupg (Show other bugs)
(Show other bugs)
Version: 9
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-26 16:27 UTC by Dams
Modified: 2007-04-18 16:54 UTC (History)
3 users (show)

Fixed In Version: 1.4.2-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-05 15:46:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dams 2003-05-26 16:27:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
the %post scriptlet in gnupg package doesnt check if info files are installed or
not. As info files are doc files, when installing the package with
"--excludedocs", the %post scriptlet says there is no such files or directories.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm -Uvh --excludedocs gnupg*rpm

    

Actual Results:  Preparing...               
########################################### [100%]
   1:gnupg                  ########################################### [100%]
install-info: No such file or directory for /usr/share/info/gpg.info.gz
install-info: No such file or directory for /usr/share/info/gpgv.info.gz


Expected Results:  install-info should not have complained

Additional info:

install-info should be redirected to >/dev/null or info files presence should be
checked before running install-info

Comment 1 Ville Skyttä 2003-05-26 19:07:22 UTC
Additionally, the scriptlets shouldn't fail (add " || :" to the end of all
install-info commands), because that will cause upgrades to abort prematurely
before the old package is removed, leaving 2 installed versions of gnupg.


Note You need to log in before you can comment on or make changes to this bug.