Bug 91642 - redhat-config-services aborts after initiation (b/c of pygtk2-1.99.16 ? ).
Summary: redhat-config-services aborts after initiation (b/c of pygtk2-1.99.16 ? ).
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: pygtk2 (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-26 17:21 UTC by Alexander Farley
Modified: 2013-04-02 04:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-27 21:02:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexander Farley 2003-05-26 17:21:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030509

Description of problem:
When trying to start redhat-config-services the program starts the window comes
up and then immediately aborts with the following: 
(redhat-config-services:19583): libglade-WARNING **: Error loading image: Failed
to open file '/usr/share/redhat-config-services/redhat-config-services.png': No
such file or directory
 
(redhat-config-services:19583): libglade-WARNING **: could not convert string to
type `GdkPixbuf' for property `icon'
Traceback (most recent call last):
  File "/usr/share/redhat-config-services/serviceconf.py", line 270, in changed
   self.set_text_buffer()
  File "/usr/share/redhat-config-services/serviceconf.py", line 277, in
set_text_buffer
    self.txtBuffer.set_text(string.strip(x[2]),len(string.strip(x[2])))
TypeError: GtkTextBuffer.set_text() takes exactly 1 argument (2 given)
Traceback (most recent call last):
  File "/usr/share/redhat-config-services/serviceconf.py", line 557, in ?
    main()
  File "/usr/share/redhat-config-services/serviceconf.py", line 544, in main
    Gui()
  File "/usr/share/redhat-config-services/serviceconf.py", line 217, in __init__
    self.changed(self.clstServices.get_selection(), None)
  File "/usr/share/redhat-config-services/serviceconf.py", line 270, in changed
   self.set_text_buffer()
  File "/usr/share/redhat-config-services/serviceconf.py", line 277, in
set_text_buffer
    self.txtBuffer.set_text(string.strip(x[2]),len(string.strip(x[2])))
TypeError: GtkTextBuffer.set_text() takes exactly 1 argument (2 given)


Version-Release number of selected component (if applicable):
redhat-config-servics-0.8.5-1

How reproducible:
Always

Steps to Reproduce:
1.Start redhat-config-services.
2.Program starts, window comes up and then aborts.
3.
    

Actual Results:  The program died.

Expected Results:  The window would have stayed open and the program would have run.

Additional info:

I am running pygtk2-1.99.16-3 and pygtk2-libglade-1.99.16-3, which I believe are
causing the problem. The program did not abort before the upgrade to the 1.99.16
series.

Comment 1 Daniel Walsh 2003-05-27 14:35:55 UTC
It is running fine on my python-2.2.2-26.  What version of Red Hat are you
running on?

Dan

Comment 2 Alexander Farley 2003-05-27 14:55:30 UTC
I am running the latest (as of May 27, 2003) packages for Rawhide. This includes
python-2.2.2-26, gnome-python2-1.99.14-5, gnome-python2-canvas-1.99.15-5,
pygtk2-1.99.16-3, pygtk2-libglade-1.99.16-3, rhpl-0.101.1-1, and chkconfig-1.3.8-2.

Comment 3 Daniel Walsh 2003-05-27 15:22:21 UTC
Need some kind of compatibility until all systems upgraded to new api.

Comment 4 Jonathan Blandford 2003-05-27 19:43:56 UTC
2002-12-28  James Henstridge  <james@daa.com.au>
                                                                                
        * gtk/gtk.override (_wrap_gtk_text_buffer_set_text): get rid of
        len argument all together.  The first argument knows its length.
This seems to be the change.  I can add a compat function for this.

Comment 5 Jonathan Blandford 2003-05-27 21:02:07 UTC
I built a compat version of that function into Rawhide.  pygtk won't traceback. 


Note You need to log in before you can comment on or make changes to this bug.