Bug 91644 - gtkhtml3-3.0.4-1 requires and provides wrong .so
Summary: gtkhtml3-3.0.4-1 requires and provides wrong .so
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gtkhtml2
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-26 17:34 UTC by Kaj J. Niemi
Modified: 2007-04-18 16:54 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2003-05-27 13:59:57 UTC


Attachments (Terms of Use)

Description Kaj J. Niemi 2003-05-26 17:34:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030509

Description of problem:
% sudo rpm -Fvh gtkhtml3-3.0.4-1.i386.rpm gtkhtml3-devel-3.0.4-1.i386.rpm
error: Failed dependencies:
        libgal-2.0.so.3 is needed by gtkhtml3-3.0.4-1
        libgtkhtml-3.0.so.1 is needed by gtkhtml3-3.0.4-1
        libgtkhtml-a11y-3.0.so.1 is needed by gtkhtml3-3.0.4-1
        libgtkhtml-3.0.so.1 is needed by (installed) evolution-1.3.3-2
        libgtkhtml-a11y-3.0.so.1 is needed by (installed) evolution-1.3.3-2
%

If we ignore the requirements of evolution and take a closer look at what
gtkhtml3 requires and provides we notice:

% rpm -qp --provides gtkhtml3-3.0.4-1.i386.rpm
libgnome-gtkhtml-editor-3.0.so
libgtkhtml-3.0.so.2
libgtkhtml-a11y-3.0.so.2
gtkhtml3 = 3.0.4-1

% rpm -qp --requires gtkhtml3-3.0.4-1.i386.rpm|grep gtkht
libgtkhtml-3.0.so.1
libgtkhtml-a11y-3.0.so.1
libgtkhtml-a11y-3.0.so.2

Same thing seems to be the problem with libgal2-1.99.6-1, I'll file a separate
bug on that...

Filed under gtkhtml2 as the component gtkhtml3 doesn't exist.

Version-Release number of selected component (if applicable):
gtkhtml3-3.0.4-1

How reproducible:
Always

Steps to Reproduce:
1. Try installing/freshening gtkhtml3
2.
3.
    

Actual Results:  Fails due to dependencies against itself

Expected Results:  Shouldn't fail

Additional info:

Comment 1 Kaj J. Niemi 2003-05-26 17:40:52 UTC
libgal2 is bug #91645, they're pretty much related to install evolution 1.3.92-1.


Comment 2 Kaj J. Niemi 2003-05-27 07:18:29 UTC
I don't get it how the dependencies are wrong on the rawhide binary build since
if I rebuild from the SRPM they're automagically correct.

Comment 3 Alexander Larsson 2003-05-27 09:14:54 UTC
this is really a gtkhml3 bug, reassigning.


Comment 4 Jeremy Katz 2003-05-27 13:59:57 UTC
Fixed in -2. 


Note You need to log in before you can comment on or make changes to this bug.