Bug 91644 - gtkhtml3-3.0.4-1 requires and provides wrong .so
gtkhtml3-3.0.4-1 requires and provides wrong .so
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gtkhtml2 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-26 13:34 EDT by Kaj J. Niemi
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-27 09:59:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaj J. Niemi 2003-05-26 13:34:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030509

Description of problem:
% sudo rpm -Fvh gtkhtml3-3.0.4-1.i386.rpm gtkhtml3-devel-3.0.4-1.i386.rpm
error: Failed dependencies:
        libgal-2.0.so.3 is needed by gtkhtml3-3.0.4-1
        libgtkhtml-3.0.so.1 is needed by gtkhtml3-3.0.4-1
        libgtkhtml-a11y-3.0.so.1 is needed by gtkhtml3-3.0.4-1
        libgtkhtml-3.0.so.1 is needed by (installed) evolution-1.3.3-2
        libgtkhtml-a11y-3.0.so.1 is needed by (installed) evolution-1.3.3-2
%

If we ignore the requirements of evolution and take a closer look at what
gtkhtml3 requires and provides we notice:

% rpm -qp --provides gtkhtml3-3.0.4-1.i386.rpm
libgnome-gtkhtml-editor-3.0.so
libgtkhtml-3.0.so.2
libgtkhtml-a11y-3.0.so.2
gtkhtml3 = 3.0.4-1

% rpm -qp --requires gtkhtml3-3.0.4-1.i386.rpm|grep gtkht
libgtkhtml-3.0.so.1
libgtkhtml-a11y-3.0.so.1
libgtkhtml-a11y-3.0.so.2

Same thing seems to be the problem with libgal2-1.99.6-1, I'll file a separate
bug on that...

Filed under gtkhtml2 as the component gtkhtml3 doesn't exist.

Version-Release number of selected component (if applicable):
gtkhtml3-3.0.4-1

How reproducible:
Always

Steps to Reproduce:
1. Try installing/freshening gtkhtml3
2.
3.
    

Actual Results:  Fails due to dependencies against itself

Expected Results:  Shouldn't fail

Additional info:
Comment 1 Kaj J. Niemi 2003-05-26 13:40:52 EDT
libgal2 is bug #91645, they're pretty much related to install evolution 1.3.92-1.
Comment 2 Kaj J. Niemi 2003-05-27 03:18:29 EDT
I don't get it how the dependencies are wrong on the rawhide binary build since
if I rebuild from the SRPM they're automagically correct.
Comment 3 Alexander Larsson 2003-05-27 05:14:54 EDT
this is really a gtkhml3 bug, reassigning.
Comment 4 Jeremy Katz 2003-05-27 09:59:57 EDT
Fixed in -2. 

Note You need to log in before you can comment on or make changes to this bug.