Bug 91645 - libgal2-1.99.6-1 requires and provides wrong .so
libgal2-1.99.6-1 requires and provides wrong .so
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: libgal7 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-26 13:38 EDT by Kaj J. Niemi
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-27 10:06:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaj J. Niemi 2003-05-26 13:38:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030509

Description of problem:
% sudo rpm -Fvh libgal2-1.99.6-1.i386.rpm libgal2-devel-1.99.6-1.i386.rpm
error: Failed dependencies:
        libgal-2.0.so.2 is needed by libgal2-1.99.6-1
        libgal-2.0.so.2 is needed by (installed) gtkhtml3-3.0.3-1
%

If we ignore the requirements of gtkhtml3 and take a closer look at what libgal2
requires and provides we notice:

% rpm -qp --provides libgal2-1.99.6-1.i386.rpm
libgal-2.0.so.3
libgal-a11y-2.0.so
libgal2 = 2:1.99.6-1

% rpm -qp --requires libgal2-1.99.6-1.i386.rpm|grep gal
libgal-2.0.so.2

Same thing seems to be the problem with gtkhtml3-3.0.4-1, I filed a separate bug
(bug #91644) against it 

Filed under libgal7 as the component libgal2 doesn't exist.

Version-Release number of selected component (if applicable):
libgal2-1.99.6-1

How reproducible:
Always

Steps to Reproduce:
1. Try installing/freshening libgal2
2.
3.
    

Actual Results:  Fails due to dependencies against itself

Expected Results:  Shouldn't fail

Additional info:
Comment 1 Kaj J. Niemi 2003-05-27 03:08:03 EDT
I don't get it how the dependencies are wrong on the rawhide binary build since
if I rebuild from the SRPM they're automagically correct.
Comment 2 Kaj J. Niemi 2003-05-27 10:06:45 EDT
This one got fixed in release -2 also, see bug #91644.

Note You need to log in before you can comment on or make changes to this bug.