Bug 91664 - files are not stripped
files are not stripped
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: utempter (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-26 18:33 EDT by acount closed by user
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version: 0.5.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-30 03:18:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description acount closed by user 2003-05-26 18:33:17 EDT
Description of problem:

utempter bin files are not stripped

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
Comment 1 Mike A. Harris 2003-05-30 00:44:09 EDT
Red Hat Linux intentionally does not strip all files completely since about
Red Hat Linux 8.0.  This facilitates receiving better backtraces from core
dumps.

[root@devel cone-0.50]# file /usr/sbin/utempter
/usr/sbin/utempter: setgid ELF 32-bit LSB executable, Intel 80386, version 1
(SYSV), dynamically linked (uses shared libs), not stripped
[root@devel cone-0.50]# file /usr/X11R6/bin/XFree86
/usr/X11R6/bin/XFree86: setuid ELF 32-bit LSB executable, Intel 80386, version 1
(SYSV), dynamically linked (uses shared libs), not stripped
[root@devel cone-0.50]# file /usr/bin/pine
/usr/bin/pine: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV),
dynamically linked (uses shared libs), not stripped

Comment 2 Mike A. Harris 2003-05-30 00:46:30 EDT
* Thu Jun 20 2002 Elliot Lee <sopwith@redhat.com> 0.5.2-9
- Don't strip binary
Comment 3 Mike A. Harris 2003-05-30 01:44:00 EDT
Ah, I think I see the problem here...

pts/2 mharris@porkchop:~/rpmbuild/RPMS/usr/sbin$ objdump -h utempter |grep .debug
 23 .debug_aranges 00000078  00000000  00000000  00001388  2**3
 24 .debug_pubnames 00000040  00000000  00000000  00001400  2**0
 25 .debug_info   00002fc5  00000000  00000000  00001440  2**0
 26 .debug_abbrev 000003cf  00000000  00000000  00004405  2**0
 27 .debug_line   000004c9  00000000  00000000  000047d4  2**0
 28 .debug_frame  00000080  00000000  00000000  00004ca0  2**2
 29 .debug_str    000023e2  00000000  00000000  00004d20  2**0
 30 .debug_ranges 00000018  00000000  00000000  00007102  2**0


However if you rebuild utempter, this stuff gets stripped:

pts/2 mharris@porkchop:~/rpmbuild/RPMS/usr/sbin$ objdump -h utempter |grep .debug
pts/2 mharris@porkchop:~/rpmbuild/RPMS/usr/sbin$


Probably what happened, was utempter got built during RHL 9 development when
rpm's stripping was broken or something and didn't get stripped properly.
The debug symbols should be getting stripped by rpm and put into the
utempter-debuginfo rpm, but it seems like that didn't happen.

Rebuilding in rawhide to get rid of the .debug sections into .debuginfo files.
Comment 4 Mike A. Harris 2003-05-30 03:18:06 EDT
Should be fixed in rawhide

Note You need to log in before you can comment on or make changes to this bug.