Bug 91680 - (NET TULIP) kernel-2.4.20-13.7 breaks networking with weird PCI errors
Summary: (NET TULIP) kernel-2.4.20-13.7 breaks networking with weird PCI errors
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i586 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-27 05:15 UTC by Bill Nottingham
Modified: 2014-03-17 02:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-29 02:09:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -v output (1.59 KB, text/plain)
2003-05-27 05:16 UTC, Bill Nottingham
no flags Details

Description Bill Nottingham 2003-05-27 05:15:49 UTC
P100, 128MB. lspci (gathered under 2.4.18-27.7.x) is attached.

Using de4x5 for eth0 for the 21040, and tulip for the Lite-On.
tulip has carrier detection issues on this 21040 since 2.4.9-ish, if
not earlier.

Also has pcmcia that fails due to the missing directory, but I'm sure that's
elsewhere in bugzilla.


May 26 00:27:34 sulaco kernel: eth0: DE434/5 at 0xf880 (PCI bus 0, device 8),
h/w address 08:00:2b:e6:d2:ca,
May 26 00:27:34 sulaco kernel:       and requires IRQ10 (provided by PCI BIOS).
May 26 00:27:34 sulaco kernel: de4x5.c:V0.546 2001/02/22 davies@maniac.ultranet.com
May 26 00:27:34 sulaco kernel: eth0: media is TP.
May 26 00:27:34 sulaco kernel: Linux Tulip driver version 0.9.15-pre12 (Aug 9, 2002)
May 26 00:27:34 sulaco kernel: PCI: Unable to reserve I/O region #1:80@f880 for
device 00:08.0
May 26 00:27:34 sulaco kernel: PCI: Unable to reserve I/O region #1:80@f880 for
device 00:08.0
May 26 00:27:34 sulaco kernel: tulip1:  MII transceiver #1 config 3000 status
7809 advertising 01e1.
May 26 00:27:35 sulaco kernel: eth1: Lite-On 82c168 PNIC rev 32 at 0xc883c400,
00:A0:CC:57:D8:07, IRQ 15.

Basically, the driver initializes, but the card doesn't pass data. I'm presuming
it's because of the PCI errors, but it could be a generic driver bug.

Comment 1 Bill Nottingham 2003-05-27 05:16:08 UTC
Created attachment 91982 [details]
lspci -v output

Comment 2 Bill Nottingham 2003-05-27 05:18:38 UTC
Oddly, the PCI errors appear to be in regards to the de4x5 driver, but it's the
tulip driver that doesn't work.

Comment 3 Jeff Garzik 2004-06-14 17:13:33 UTC
Are de4x5 and tulip both getting loaded?


Comment 4 Bill Nottingham 2004-06-29 02:09:32 UTC
Appears to be working in FC1.


Note You need to log in before you can comment on or make changes to this bug.