Bug 91738 - upgrade with raid/lvm fails with wrong root and/or fstab error
upgrade with raid/lvm fails with wrong root and/or fstab error
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-27 15:26 EDT by Ralf Hansen
Modified: 2007-04-18 12:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-24 19:29:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fstab (1.12 KB, text/plain)
2003-05-27 15:35 EDT, Ralf Hansen
no flags Details
anaconda.log (4.57 KB, text/plain)
2003-05-27 15:36 EDT, Ralf Hansen
no flags Details
/tmp/syslog (14.93 KB, text/plain)
2003-06-02 03:47 EDT, Ralf Hansen
no flags Details

  None (edit)
Description Ralf Hansen 2003-05-27 15:26:06 EDT
Description of problem:The installation tries to mount the partions but seems to use a wrong partion as '/', the right '/' would be '/dev/vg_system/root', it uses '/dev/md0' first which is '/boot'.It complains about errors with fstab and stops the upgrade process.I tried to upgrade from redhat-8.0. The LVM is on /dev/md1.I can manually mount /dev/vg_system/root and after that chroot with 'mount -av' works. I tried a kickstart installation as upgrade but with no success, too./etc/fstab:/dev/vg_system/root     /                       ext2    defaults        1 1/dev/md0                /boot                   ext2    defaults        1 2none                    /dev/pts                devpts  gid=5,mode=620  0 0/dev/vg_system/home     /home                   ext3    defaults        1 2/dev/vg_system/opt      /opt                    ext3    defaults        1 2none                    /proc                   proc    defaults        0 0none                    /dev/shm                tmpfs   defaults        0 0/dev/vg_system/tmp      /tmp                    ext2    defaults        1 2/dev/vg_system/usr      /usr                    ext3    defaults        1 2/dev/vg_system/local    /usr/local              ext3    defaults        1 2/dev/vg_system/var      /var                    ext3    defaults        1 2/dev/sdb2               swap                    swap    defaults        0 0/dev/sda2               swap                    swap    defaults        0 0/dev/fd0                /mnt/floppy             auto    noauto,owner,kudzu 0 0/dev/cdrom              /mnt/cdrom              iso9660 noauto,owner,kudzu,ro 0 0Version-Release number of selected component (if applicable):How reproducible:Steps to Reproduce:1.install redhat-8.0 setup like above2.try upgrade    Actual results:during upgrade error about fstab, mount failes and upgrade stoppedExpected results:Additional info:anaconda.log:[...]* Running kickstart %pre script(s)* All kickstart %pre script(s) have been run* moving (1) to step findrootparts* going to mount /tmp/md0 on /mnt/sysimage* going to mount /dev/vg_system/var on /mnt/sysimage* going to mount /dev/vg_system/local on /mnt/sysimage* going to mount /dev/vg_system/usr on /mnt/sysimage* going to mount /dev/vg_system/tmp on /mnt/sysimage* going to mount /dev/vg_system/opt on /mnt/sysimage* going to mount /dev/vg_system/home on /mnt/sysimage* going to mount /dev/vg_system/root on /mnt/sysimage* moving (1) to step partitionobjinit* moving (1) to step upgrademount* going to mount /dev/vg_system/root on /mnt/sysimage as ext2* going to mount /dev/vg_system/root on /mnt/sysimage
Comment 1 Ralf Hansen 2003-05-27 15:35:13 EDT
Created attachment 92007 [details]
fstab
Comment 2 Ralf Hansen 2003-05-27 15:36:11 EDT
Created attachment 92008 [details]
anaconda.log
Comment 3 Michael Fulbright 2003-05-27 17:15:52 EDT
When asked about which installation(s) you would like to upgrade which one(s)
are you presented with? From the log it looks like we are trying to mount
/dev/vg_system/root as the last thing we do.

Comment 4 Ralf Hansen 2003-05-28 04:00:52 EDT
It was 'Redhat Linux 8.0 (/dev/vg_system/root)', the only choise. I tried in
english upgrade now (german before). The requester have the title 'Mount failed'
and the text 'One or more of the filesystems listed in the /etc/fstab on your
linux system cannot be mountet. ...'.
Comment 5 Michael Fulbright 2003-05-29 17:21:01 EDT
When this error occurs look on VC3 (cntl-alt-f3) and see if you can find any log
output related to the failure to mount the partition.
Comment 6 Ralf Hansen 2003-06-02 03:46:06 EDT
At 'VC3' I see exactly the same as in the attached 'anaconda.log'.
At 'VC4' I messages from kernel and other components, which is the same as im
'/tmp/syslog'.
In both I don't see any error messages from 'mount'.

I attach the 'syslog' now, too.
Comment 7 Ralf Hansen 2003-06-02 03:47:32 EDT
Created attachment 92074 [details]
/tmp/syslog
Comment 8 Michael Fulbright 2003-06-19 14:46:53 EDT
If you run 'e2label /dev/md0' what does it say the label is?
Comment 9 Ralf Hansen 2003-07-14 11:36:41 EDT
The label of /dev/md0 is '/boot'. There is no 'LABEL=' used in /etc/fstab, there
are only device files or 'none'.
Comment 10 Jeremy Katz 2003-07-24 19:29:35 EDT
Fix for this in CVS.

Note You need to log in before you can comment on or make changes to this bug.