Bug 91780 - pygtk2-1.99.16-3.src.rpm won't build
pygtk2-1.99.16-3.src.rpm won't build
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: pygtk2 (Show other bugs)
1.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-27 21:37 EDT by sean
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-28 01:00:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from rpmbuild --rebuild pygtk2 (61.75 KB, text/plain)
2003-05-27 22:10 EDT, sean
no flags Details

  None (edit)
Description sean 2003-05-27 21:37:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030524

Description of problem:
building pygtk2-1.99.16-3.src.rpm with gcc-3.2.3-4 and rpm-4.2-0.69:

Processing files: pygtk2-libglade-1.99.16-3
error: File not found by glob: /var/tmp/pygtk-root/usr/lib/python?.?/site-packag
es/gtk-2.0/gtk/glademodule.so
Processing files: pygtk2-devel-1.99.16-3
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHave
Prefix) <= 4.0-1
Requires: /bin/sh pygtk2 = 1.99.16
 
 
RPM build errors:
    File not found by glob: /var/tmp/pygtk-root/usr/lib/python?.?/site-packages/
gtk-2.0/atkmodule.so
    File not found by glob: /var/tmp/pygtk-root/usr/lib/python?.?/site-packages/
gtk-2.0/gobjectmodule.so
    File not found by glob: /var/tmp/pygtk-root/usr/lib/python?.?/site-packages/
gtk-2.0/pangomodule.so
    File not found by glob: /var/tmp/pygtk-root/usr/lib/python?.?/site-packages/
gtk-2.0/gtk/_gtkmodule.so
    File not found by glob: /var/tmp/pygtk-root/usr/lib/python?.?/site-packages/
gtk-2.0/gtk/glademodule.so



These files are all there without the .so. Is the .spec file wrong ( which wants
the .so ) or pygtk2 install itself?



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpmbuild --rebuild pygtk2
2.
3.
    

Additional info:
Comment 1 Matt Wilson 2003-05-27 21:44:09 EDT
do you have the required development packages installed?  Please attach the full
build output.
 
Comment 2 sean 2003-05-27 22:10:32 EDT
Created attachment 92016 [details]
output from rpmbuild --rebuild pygtk2
Comment 3 sean 2003-05-27 22:13:39 EDT
AFAIK I have all the developemnt packages. Any in particular?

As long as you're getting the build output, what's all those "Could not write
method ( function )" errors?
Comment 4 Matt Wilson 2003-05-27 22:28:27 EDT
That's just stuff that can't be autogenerated.

Seems you have the devel packages you need.  What version of automake and libool?
Comment 5 sean 2003-05-28 01:00:27 EDT
Good guess.

rpm -q automake libtool
automake-1.7.5-1
libtool-1.5-1

I went back to libtool-1.4.3. Now it builds.

Note You need to log in before you can comment on or make changes to this bug.