Bug 9189 - Installer doesn't recognize correct size of root partition
Installer doesn't recognize correct size of root partition
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-07 17:32 EST by kithanas
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-23 11:09:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kithanas 2000-02-07 17:32:51 EST
While attempting to install Red Hat Linux 6.1 on a HP Omnibook 4000C (32mb
RAM, 773MB HDD) via NFS, the installer crashed.

I laid out my partitions as follows:

/boot         16M
/            691M
Linux swap    64M


I selected Gnome workstation install. According the installer this required
563M, and my root partition is 691M, plenty of room right? Wrong. The
installer reported that I need 37M more space on /. What is going on? Is
the space the selected packages require in addition to something else? Or
is the installer not seeing the correct size of the disk?

I then tried doing a custom install that required only 365M only to have it
give a signal 7 error halfway through the package installation process.
Could you clarify what might be happening here?

The only thing I can think of that might be causing this problem is that
the bios detects the hard drive as being 773MB (1571 C/16 H/63 S) while the
Linux installer detects it as being 772MB (785 C/32 H/63 S). Is there
anyway around this problem?
Comment 1 Jay Turner 2000-02-23 11:09:59 EST
A GNOME Workstation installation actually required about 750M of disk space, as
it creates room to grow for the installation.  This factor is hard coded into
the installer, and that is why you are getting the error message about needing
more disk space.

In reference to the signal 7 that you are receiving in the middle of the
installation, this is because your machine ran out of memory.  Are you running
the installer in GUI or text mode??  I would highly recommend running the text
installer with only 32M RAM.  To get into the text installer, just type "linux
text" at the boot prompt and it will launch you into the text-based installer,
which takes a considerable amount less RAM.

Note You need to log in before you can comment on or make changes to this bug.