Bug 919531 - [abrt] policycoreutils-gui-2.1.13-56.fc18: __init__.py:78:get_all_entrypoint_domains:NameError: global name 're' is not defined
Summary: [abrt] policycoreutils-gui-2.1.13-56.fc18: __init__.py:78:get_all_entrypoint_...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: policycoreutils
Version: 18
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:2ffd940510bd2940f74e8a0a075...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-08 18:20 UTC by Flóki Pálsson
Modified: 2013-04-03 04:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-03 04:51:28 UTC


Attachments (Terms of Use)
File: backtrace (103.35 KB, text/plain)
2013-03-08 18:20 UTC, Flóki Pálsson
no flags Details
File: core_backtrace (466 bytes, text/plain)
2013-03-08 18:20 UTC, Flóki Pálsson
no flags Details
File: environ (270 bytes, text/plain)
2013-03-08 18:20 UTC, Flóki Pálsson
no flags Details

Description Flóki Pálsson 2013-03-08 18:20:02 UTC
Description of problem:
starting s-c-linux

Version-Release number of selected component:
policycoreutils-gui-2.1.13-56.fc18

Additional info:
cmdline:        /usr/bin/python -Es /usr/share/system-config-selinux/system-config-selinux.py
dso_list:       policycoreutils-python-2.1.13-56.fc18.x86_64
executable:     /usr/share/system-config-selinux/system-config-selinux.py
kernel:         3.8.1-201.fc18.x86_64
uid:            0

Comment 1 Flóki Pálsson 2013-03-08 18:20:05 UTC
Created attachment 707162 [details]
File: backtrace

Comment 2 Flóki Pálsson 2013-03-08 18:20:09 UTC
Created attachment 707163 [details]
File: core_backtrace

Comment 3 Flóki Pálsson 2013-03-08 18:20:11 UTC
Created attachment 707164 [details]
File: environ

Comment 4 Daniel Walsh 2013-03-08 21:42:13 UTC
Fixed in policycoreutils-gui-2.1.13-57.fc18

Comment 5 Flóki Pálsson 2013-03-10 12:30:45 UTC
http://koji.fedoraproject.org/koji/buildinfo?buildID=401242
RPMs 	No RPMs

Comment 6 Fedora Update System 2013-03-28 12:13:56 UTC
policycoreutils-2.1.13-59.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/policycoreutils-2.1.13-59.fc18

Comment 7 Fedora Update System 2013-03-29 01:35:29 UTC
Package policycoreutils-2.1.13-59.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing policycoreutils-2.1.13-59.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-4555/policycoreutils-2.1.13-59.fc18
then log in and leave karma (feedback).

Comment 8 Nick Fenwick 2013-03-29 04:30:15 UTC
Do you mean 2.1.13-59 or 2.1.13-58?  I just ran into this bug with policycoreutils-2.1.13-56.fc18 installed.  Tried the 'yum update' above but got:

No package policycoreutils-2.1.13-59.fc18 available.

Altered yum command to: yum update --enablerepo=updates-testing policycoreutils

Got:

Updated:
  policycoreutils.x86_64 0:2.1.13-58.fc18

Dependency Updated:
  policycoreutils-devel.x86_64 0:2.1.13-58.fc18    policycoreutils-gui.x86_64 0:2.1.13-58.fc18    policycoreutils-python.x86_64 0:2.1.13-58.fc18   


These installed and the bug seems to be fixed, 'SELinux Administration' program now loads up without error.

Comment 9 Fedora Update System 2013-04-03 04:51:30 UTC
policycoreutils-2.1.13-59.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.