Bug 91978 - Warning message when executing iwconfig
Warning message when executing iwconfig
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: wireless-tools (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-30 11:13 EDT by Jose Cintron
Modified: 2015-01-07 19:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-15 12:33:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jose Cintron 2003-05-30 11:13:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
When I attempt to check or set my wireless configuration I get the following
message...

Warning: Driver for device eth1 has been compiled with version 15
of Wireless Extension, while this program is using version 13.
Some things may be broken...

eth1      IEEE 802.11-DS  ESSID:""  Nickname:"anubis.hamunaptra.net"
          Mode:Managed  Frequency:2.457GHz  Access Point: 44:44:44:44:44:44
          Bit Rate:2Mb/s   Tx-Power=15 dBm   Sensitivity:1/3
          Retry limit:4   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0/92  Signal level:134/153  Noise level:134/153
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


I saw a reference to this message in Bugzilla 50789.  I am using an Orinoco Gold
Card

Version-Release number of selected component (if applicable):
wireless-tools-25-1

How reproducible:
Always

Steps to Reproduce:
1.Installed RH 8
2.Applied all available patches thru UP2DATE
3.Open a command line terminal
4.Type /sbin/iwconfig
    

Actual Results:  
Warning: Driver for device eth1 has been compiled with version 15
of Wireless Extension, while this program is using version 13.
Some things may be broken...

eth1      IEEE 802.11-DS  ESSID:""  Nickname:"anubis.hamunaptra.net"
          Mode:Managed  Frequency:2.457GHz  Access Point: 44:44:44:44:44:44
          Bit Rate:2Mb/s   Tx-Power=15 dBm   Sensitivity:1/3
          Retry limit:4   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0/92  Signal level:134/153  Noise level:134/153
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Additional info:

I even tried to download the source for wireless-tools-25-1 and compiled them
the result was the same...
Comment 1 Bill Nottingham 2003-05-30 15:27:09 EDT
This is because of the updated drivers in the new errata kernel.
Comment 2 Jose Cintron 2003-06-01 14:14:21 EDT
Is there an updated version of the Wireless-Tools for RH8?  I know the latest
for RH9 is 25-8 (or something like that).
Comment 3 Jose Cintron 2003-06-01 16:25:39 EDT
Just tried the wireless-tools for RH9 in my RH8 (with updated Kernel) and
everything is working fine and there is no more warning message.
Comment 4 Bill Nottingham 2004-03-15 12:33:14 EST
This is not going to be fixed for that release at this point; it's fixed in
current development trees for the kernel shipped there.

Note You need to log in before you can comment on or make changes to this bug.