Bug 9200 - vim contacts DISPLAY even in non-gui mode
Summary: vim contacts DISPLAY even in non-gui mode
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vim   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-08 01:56 UTC by Kjetil T. Homme
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-10 15:05:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kjetil T. Homme 2000-02-08 01:56:32 UTC
Try:

DISPLAY=haey.ifi.uio.no:0 TERM=xterm
export DISPLAY TERM
vim

You will be greeted by
X connection to haey.ifi.uio.no:0 broken (explicit kill or server
shutdown).

This is due to the vim code unconditionally contacting the X server
even in text mode!  That's just utterly bogus, IMO.

The offending feature is XTERM_CLIP.

Workaround:  Set TERM to vt102 instead of xterm...

Comment 1 Nalin Dahyabhai 2000-02-10 15:05:59 UTC
This should be fixed in vim-5.6-4 in Raw Hide or vim-5.6-5 in Piglet.  Please
reopen this bug if you find that upgrading the vim-enhanced package does not
correct the problem.


Note You need to log in before you can comment on or make changes to this bug.