Bug 92006 - Kudzu hanging on boot.
Kudzu hanging on boot.
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-30 20:16 EDT by Brian Roy
Modified: 2014-03-16 22:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-23 16:05:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of kudzu (33.47 KB, text/plain)
2003-06-02 12:43 EDT, Brian Roy
no flags Details
Kudzu strace with -f... sorry about that wasn't thinking... (80.63 KB, text/plain)
2003-06-02 12:55 EDT, Brian Roy
no flags Details
/etc/pcmcia/config (41.79 KB, text/plain)
2003-06-02 13:06 EDT, Brian Roy
no flags Details

  None (edit)
Description Brian Roy 2003-05-30 20:16:06 EDT
Description of problem:


Version-Release number of selected component (if applicable):
Kernel 2.4.20-13.9



How reproducible:

Upgraded v8 to v9 (Workstation install)
Updated system via RHN (no update to kudzu)
Reboot system with new kernel


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
Contents of hwconf:

-
class: OTHER
bus: PCI
detached: 0
driver: agpgart
desc: "Intel Corp.|440BX/ZX/DX - 82443BX/ZX/DX Host bridge"
vendorId: 8086
deviceId: 7190
subVendorId: 0000
subDeviceId: 0000
pciType: 1
-
class: OTHER
bus: PCI
detached: 0
driver: ignore
desc: "Intel Corp.|440BX/ZX/DX - 82443BX/ZX/DX AGP bridge"
vendorId: 8086
deviceId: 7191
subVendorId: 0000
subDeviceId: 0000
pciType: 1
-
class: OTHER
bus: PCI
detached: 0
driver: unknown
desc: "Intel Corp.|82371AB/EB/MB PIIX4 ISA"
vendorId: 8086
deviceId: 7110
subVendorId: 0000
subDeviceId: 0000
pciType: 1
-
class: OTHER
bus: PCI
detached: 0
driver: unknown
desc: "Intel Corp.|82371AB/EB/MB PIIX4 IDE"
vendorId: 8086
deviceId: 7111
subVendorId: 0000
subDeviceId: 0000
pciType: 1
-
class: OTHER
bus: PCI
detached: 0
driver: unknown
desc: "Intel Corp.|82371AB/EB/MB PIIX4 ACPI"
vendorId: 8086
deviceId: 7113
subVendorId: 0000
subDeviceId: 0000
pciType: 1
-
class: OTHER
bus: USB
detached: 0
driver: unknown
desc: "USB UHCI Root Hub"
usbclass: 9
usbsubclass: 0
usbprotocol: 0
usbbus: 1
usblevel: 0
usbport: 0
vendorId: 0000
deviceId: 0000
usbprod: USB UHCI Root Hub
-
class: MOUSE
bus: PSAUX
detached: 0
device: psaux
driver: genericps/2
desc: "Generic Mouse (PS/2)"
-
class: AUDIO
bus: PCI
detached: 0
driver: maestro3
desc: "ESS Technology|ES1983S Maestro-3i PCI Audio Accelerator"
vendorId: 125d
deviceId: 1998
subVendorId: 1028
subDeviceId: 00bb
pciType: 1
-
class: CDROM
bus: IDE
detached: 0
device: hdc
driver: ignore
desc: "SAMSUNG CD-ROM SN-124"
-
class: VIDEO
bus: PCI
detached: 0
driver: Card:ATI Rage Mobility
desc: "ATI|Rage Mobility P/M AGP 2x"
vendorId: 1002
deviceId: 4c4d
subVendorId: 1028
subDeviceId: 00bb
pciType: 1
-
class: FLOPPY
bus: MISC
detached: 1
device: fd0
driver: unknown
desc: "3.5" 1.44MB floppy drive"
-
class: HD
bus: IDE
detached: 0
device: hda
driver: ignore
desc: "IBM-DARA-212000"
physical: 23392/16/63
logical: 1467/255/63
-
class: USB
bus: PCI
detached: 0
driver: usb-uhci
desc: "Intel Corp.|82371AB/EB/MB PIIX4 USB"
vendorId: 8086
deviceId: 7112
subVendorId: 0000
subDeviceId: 0000
pciType: 1
-
class: SOCKET
bus: PCI
detached: 0
driver: yenta_socket
desc: "Texas Instruments|PCI1225"
vendorId: 104c
deviceId: ac1c
subVendorId: 1028
subDeviceId: 00bb
pciType: 1
-
class: SOCKET
bus: PCI
detached: 0
driver: yenta_socket
desc: "Texas Instruments|PCI1225"
vendorId: 104c
deviceId: ac1c
subVendorId: 1028
subDeviceId: 00bb
pciType: 1
Comment 1 Bill Nottingham 2003-05-30 21:57:57 EDT
If you skip it, does it hang if you run it from the command line later?
Comment 2 Brian Roy 2003-05-31 00:51:59 EDT
Yes. I removed it from run level 5 and the system boots fine. If I run
/etc/rc.d/init.d/kudzu start it will hang (until I kill it... as long as one hour).

I checked /var/log/messages on the off chance that there was any messaging and
saw none.
Comment 3 Bill Nottingham 2003-06-01 23:36:46 EDT
Can you strace it, and post the output?
Comment 4 Brian Roy 2003-06-02 12:43:41 EDT
Created attachment 92087 [details]
strace of kudzu

NOTE: I did ctrl-c the strace after the file had stopped growing (i.e., kudzu
had hung).

ran "strace -tt -o /var/log/kudzu.strace /etc/rc.d/init.d/kudzu start"

Brian Roy
Comment 5 Bill Nottingham 2003-06-02 12:46:52 EDT
Woops, since you straced the initscript, you'll need to add -f to follow the
processes it spawend. That output you just posted shows the shell waiting for kudzu.
Comment 6 Brian Roy 2003-06-02 12:55:09 EDT
Created attachment 92088 [details]
Kudzu strace with -f... sorry about that wasn't thinking...

Sorry about that. Here is the PID output from the run:

Process 1309 attached
Process 1310 attached
Process 1309 suspended
Process 1309 resumed
Process 1310 detached
Process 1309 detached
Process 1311 attached
Process 1311 detached
Checking for new hardwareProcess 1312 attached
Process 1308 suspended
Process 1308 resumed
Process 1312 detached
Process 1313 attached
Process 1313 detached
Process 1314 attached
Process 1308 suspended
Process 1308 resumed
Process 1314 detached
Comment 7 Bill Nottingham 2003-06-02 13:00:54 EDT
Can you attach your /etc/pcmcia/config?
Comment 8 Brian Roy 2003-06-02 13:06:13 EDT
Created attachment 92090 [details]
/etc/pcmcia/config

I did add an entry to the file so my speedstream wireless card would be
detected and assoicated with the orinoco driver (see entry at line 1894).
Comment 9 Brian Roy 2003-06-04 13:36:15 EDT
Interestingly enough... I had another issue that forced a system re-image. This 
time I loaded 9 directly from the CD (last time I upgraded an 8 install).

Kudzu runs fine. If you want the /etc/pcmcia/config and/or another strace let 
me know... very strange.

Brian Roy
Comment 10 Bill Nottingham 2005-09-23 16:05:54 EDT
Closing out bugs on older, no longer supported, releases. Apologies for any lack
of response.

Please test this bug on a current release, such as Fedora Core 4. If it persists
there, please file a new bug.

Note You need to log in before you can comment on or make changes to this bug.