This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 92044 - koffices apps fail to start
koffices apps fail to start
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: koffice (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-01 16:20 EDT by Horst Kausch
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-08 09:58:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
List of installed packages (27.03 KB, text/plain)
2003-06-05 15:05 EDT, Horst Kausch
no flags Details
strace log on kword (470.24 KB, text/plain)
2003-06-05 15:06 EDT, Horst Kausch
no flags Details

  None (edit)
Description Horst Kausch 2003-06-01 16:20:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
When starting koffice apps from the command line nothing seems to happen: it
silently returns to the command prompt after a delay of a few seconds. This is
for a clean everything install of Red Hat 9 with the glibc errata applied.  

This is probably the same as bug # 84678, however I cannot add this add as a
comment due to bugzilla bug # 88502.

Is there any additional useful information I could supply?

Version-Release number of selected component (if applicable):
koffice-1.2.1-7

How reproducible:
Always

Steps to Reproduce:
1. open gnome-terminal
2. execute command "kword"
3. command prompt returns after 3 seconds with no other result

Actual Results:  nothing happened

Expected Results:  kword should have started

Additional info:
Comment 1 Ngo Than 2003-06-02 06:31:56 EDT
strange, this issuse only appears on my machine if kdebase is not installed. I
already added requires kdebase in koffice-1.2.1-7.

Is kdebase installed on your machine?

For debugging i need some informations:
  please give me rpm package list on your machine (rpm -qa)?
  And strace log (strace -o kword.log kword)
Comment 2 Ngo Than 2003-06-05 03:53:15 EDT
sorry, works for me. any more specific way to reproduce this ? reopen then.
Comment 3 Horst Kausch 2003-06-05 15:05:33 EDT
Created attachment 92176 [details]
List of installed packages
Comment 4 Horst Kausch 2003-06-05 15:06:56 EDT
Created attachment 92177 [details]
strace log on kword
Comment 5 Horst Kausch 2003-06-05 15:08:50 EDT
Sorry for the delay in replying, but it still doesn't work for me. I have
attached my package list and strace log, as suggested. Anything else I can do?
Comment 6 Ngo Than 2003-06-30 09:01:10 EDT
does it work for you if you start kdeinit first and then kword?
or does it work for you if you start it in KDE desktop Enviroment?
Comment 7 Horst Kausch 2003-06-30 16:53:59 EDT
Running kdeinit first (in gnome) does not work either.

I then started a KDE session and kword works fine. This was the first time I ran
a KDE session in this install of RedHat Linux. Going back to a gnome session,
all koffice apps now work. 

So the problem seems to be that koffice is not properly initialised unless run
first in a KDE session.
Comment 8 Ngo Than 2003-07-08 09:58:31 EDT
ok, i have found the bug now. it should be fixed in koffice-1.2.1-13. thanks for
your report

Note You need to log in before you can comment on or make changes to this bug.