Bug 92047 - UP/BOOT kernel doesn't work on Intel D875PBZ MB with SATA
Summary: UP/BOOT kernel doesn't work on Intel D875PBZ MB with SATA
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-02 01:23 UTC by hjl
Modified: 2007-04-18 16:54 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-02 06:46:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description hjl 2003-06-02 01:23:43 UTC
When an SATA drive is attached on D875PBZ, UP kernel won't assign
an IRQ to the SATA drive and kernel will hang. SMP kernel works fine.

Comment 1 Arjan van de Ven 2003-06-02 06:26:41 UTC
looks like a defective $PIR table.

Comment 2 hjl 2003-06-02 06:41:43 UTC
I added the following to kernel spec file. It
works for me. BTW, Windows XP has no problem.
----
%ifarch %{all_x86}
# Needed for SATA drives on Intel D875PBZ motherboard.
for a in i386-BOOT i686; do
  cat >> configs/kernel-%{kversion}-$a.config <<EOF
CONFIG_X86_UP_APIC=y
CONFIG_X86_UP_IOAPIC=y
CONFIG_X86_LOCAL_APIC=y
CONFIG_X86_IO_APIC=y
EOF
done
%endif


Comment 3 Arjan van de Ven 2003-06-02 06:46:55 UTC
yup this proves the $PIR table is defective; UPAPIC makes the kernel use the
mptable not the $PIR table for interrupts.
Unfortionatly we can't enable this by default since it breaks far more than it
ever fixes.

Closing this as "NOTABUG" since it's a bios bug, and thus not a kernel bug.


Note You need to log in before you can comment on or make changes to this bug.