This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 92050 - (USB)HP 8200e USB cd writer doesn't work directly, require reboot into stock kernel
(USB)HP 8200e USB cd writer doesn't work directly, require reboot into stock ...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
http://groups.google.com/groups?dq=&h...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-01 23:26 EDT by Joseph Shraibman
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-11 00:39:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joseph Shraibman 2003-06-01 23:26:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030529

Description of problem:
See the URL.  Basically my HP 8200e cdrw won't work with the stock redhat 9
kernel (I had this problem with redhat 8 as well).  I had to boot the 2.4.20
kernel from kernel.org, then reboot with the redhat kernel to get the cdrw to
work.  I'm having similar problems with my FTDI usb->serial port but I don't
have as detailed debug info on that.

Version-Release number of selected component (if applicable):
kernel-2.4.20-13.9

How reproducible:
Always

Steps to Reproduce:
1. Plug in an HP 8200e cd writer
2. cat /proc/scsi/scsi or do a cdrecord -scanbus to show that it doesn't work.
3.
    

Actual Results:  [jks@jks-laptop /proc/scsi]$ cat scsi
Attached devices: none


Expected Results:  [jks@jks-laptop /mnt/cdrom]$ cat /proc/scsi/scsi
Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: HP       Model: CD-Writer+ 8200  Rev: 1.0f
  Type:   CD-ROM                           ANSI SCSI revision: 02

[root@jks-laptop /home/jks]# cdrecord -scanbus
Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jrg Schilling
Linux sg driver version: 3.1.24
Using libscg version 'schily-0.7'
cdrecord: Warning: using inofficial libscg transport code version (schily - Red
Hat-scsi-linux-sg.c-1.75-RH '@(#)scsi-linux-sg.c        1.75 02/10/21 Copyright
1997 J. Schilling').
scsibus0:
        0,0,0     0) 'HP      ' 'CD-Writer+ 8200 ' '1.0f' Removable CD-ROM
        0,1,0     1) *
        0,2,0     2) *
        0,3,0     3) *
        0,4,0     4) *
        0,5,0     5) *
        0,6,0     6) *
        0,7,0     7) *


Additional info:

This is obviously a redhat problem

This might be related to bug 80328
Comment 1 Joseph Shraibman 2003-06-03 12:37:37 EDT
This appears fixed in kernel-2.4.20-18.9
Comment 2 Joseph Shraibman 2003-06-04 11:56:15 EDT
Whoops.  Spoke too soon.  After I power cycled the cd burner it doesn't work
anymore.
Comment 3 Joseph Shraibman 2003-06-04 12:21:16 EDT
However my FTDI serial cable does appear to be working fine right now
Comment 4 Joseph Shraibman 2003-06-05 14:18:08 EDT
The cd burner decided to work today with the regular redhat kernel:

Jun  1 15:48:00 jks-laptop kernel: Freeing unused kernel memory: 140k freed
Jun  1 15:48:00 jks-laptop kernel: hub.c: new USB device 00:07.2-1, assigned
address 2
Jun  1 15:48:00 jks-laptop kernel: spurious 8259A interrupt: IRQ7.
Jun  1 15:48:00 jks-laptop kernel: usb.c: USB device 2 (vend/prod 0x3f0/0x107)
is not claimed by any active driver.
Jun  1 15:48:00 jks-laptop kernel: hub.c: new USB device 00:07.2-2, assigned
address 3
Jun  1 15:48:00 jks-laptop kernel: usb.c: USB device 3 (vend/prod 0x45e/0x53) is
not claimed by any active driver.
Jun  1 15:48:00 jks-laptop kernel: Initializing USB Mass Storage driver...
Jun  1 15:48:00 jks-laptop kernel: usb.c: registered new driver usb-storage
Jun  1 15:48:01 jks-laptop kernel: scsi0 : SCSI emulation for USB Mass Storage
devices
Jun  1 15:48:01 jks-laptop kernel:   Vendor: HP        Model: CD-Writer+ 8200  
Rev: 1.0f
Jun  1 15:48:01 jks-laptop kernel:   Type:   CD-ROM                            
ANSI SCSI revision: 02
Jun  1 15:48:01 jks-laptop kernel: USB Mass Storage support registered.
Jun  1 15:48:01 jks-laptop kernel: usb.c: registered new driver hid
Jun  1 15:48:01 jks-laptop kernel: : USB HID v1.10 Mouse [Microsoft Microsoft
3-Button Mouse with IntelliEye(TM)] on usb1:3.0
Jun  1 15:48:01 jks-laptop kernel: hid-core.c: v1.8.1 Andreas Gal, Vojtech
Pavlik <vojtech@suse.cz>
Jun  1 15:48:01 jks-laptop kernel: hid-core.c: USB HID support drivers
Jun  1 15:48:01 jks-laptop kernel: mice: PS/2 mouse device common for all mice
Jun  1 15:48:01 jks-laptop kernel: EXT3 FS 2.4-0.9.19, 19 August 2002 on
ide0(3,4), internal journal
Jun  1 15:48:01 jks-laptop kernel: Adding Swap: 2048276k swap-space (priority -1)
Jun  1 15:48:01 jks-laptop kernel: kjournald starting.  Commit interval 5 seconds
Jun  1 15:48:01 jks-laptop kernel: EXT3 FS 2.4-0.9.19, 19 August 2002 on
ide0(3,2), internal journal
Jun  1 15:48:01 jks-laptop kernel: EXT3-fs: mounted filesystem with ordered data
mode.
Jun  1 15:48:01 jks-laptop kernel: loop: loaded (max 8 devices)
Jun  1 15:48:01 jks-laptop kernel: cs: IO port probe 0x0c00-0x0cff: clean.
Jun  1 15:48:01 jks-laptop kernel: cs: IO port probe 0x0100-0x04ff: excluding
0x378-0x37f 0x4d0-0x4d7
Jun  1 15:48:01 jks-laptop kernel: cs: IO port probe 0x0a00-0x0aff: clean.
Jun  1 15:48:01 jks-laptop kernel: Attached scsi CD-ROM sr0 at scsi0, channel 0,
id 0, lun 0
Jun  1 15:48:01 jks-laptop kernel: sr0: scsi3-mmc drive: 24x/24x writer cd/rw
xa/form2 cdda tray

... so I'd say the the problem is itermittent
Comment 5 Chandrasekhar KG 2003-09-05 08:18:35 EDT
I have run into problems with my HP 8200e too.
It seems persistent from Redhat 7.3 through 9.0
Plugin the CD-writer and power it on while the machine is running and it hangs
the machine.
My configuration: Athlon XP 1800+ /512MB PC 2100 RAM/Nvidia N266VM Motherboard 

Can someone please advice?

Of course, recompiling the kernel fixes the problem, but was wondering whether
something can be done so the stock kernel works fine.
Comment 6 Pete Zaitcev 2004-01-17 14:28:30 EST
Anyone had a chance to try the 8200e on Fedora with 2.4.22-1.2140 yet?
I had some significant usb-storage upgrades there.
Comment 7 Joseph Shraibman 2004-01-17 18:36:25 EST
Can I install a kernel from Fedora on a redhat 9 machine?
Comment 8 Pete Zaitcev 2004-01-17 18:43:29 EST
FC1 kernel is compatible, and I used it over RHL9 userland.
They might yet be unified, in the same way 7.x & 8 were.
However, external modules are virtually guaranteed to break,
e.g. Nvidia and such. So, just use it for testing.
Comment 9 Joseph Shraibman 2004-01-17 19:09:47 EST
Where can I get the rpm?  Do I have to download the fedora iso and
unpack it?
Comment 10 Joseph Shraibman 2004-01-17 19:14:19 EST
Nevermind, found this:

http://download.fedora.redhat.com/pub/fedora/linux/core/updates/1/i386/

Is there some reason you want me to test 2140 and not 2149?
Comment 11 Pete Zaitcev 2004-01-17 19:33:32 EST
Any one works. Just the updates to usb-storage were in -1.2140.
Comment 12 Joseph Shraibman 2004-01-17 22:55:45 EST
Nope, doesn't work.  Same as before.
Comment 13 Pete Zaitcev 2004-08-10 15:26:11 EDT
Joseph, I'm really sorry, but this is a WONTFIX. It just takes 
too much to backport necessary fixes. Please switch to FC2 which
has a way better 2.6 kernel. File a new bug if it fails to work.
Comment 14 Joseph Shraibman 2004-08-11 00:16:08 EDT
I tried it with the latest fedora core 2 kernel and it doesn't work
either.  I'm trying to change the product to fedora core but I don't
have a '2' option on the version.

[root@jks-laptop ~]# uname -a
Linux jks-laptop 2.4.22-1.2199.nptl #1 Wed Aug 4 12:25:07 EDT 2004
i686 athlon i386 GNU/Linux


Aug 11 00:04:26 jks-laptop kernel: usb.c: USB device 3 (vend/prod
0x3f0/0x107) is not claimed by any active driver.
Aug 11 00:04:26 jks-laptop kernel: cs: IO port probe 0x0c00-0x0cff: clean.
Aug 11 00:04:26 jks-laptop kernel: cs: IO port probe 0x0100-0x04ff:
excluding 0x378-0x37f 0x4d0-0x4d7
Aug 11 00:04:26 jks-laptop kernel: cs: IO port probe 0x0a00-0x0aff: clean.
Aug 11 00:04:26 jks-laptop kernel: SCSI subsystem driver Revision: 1.00
Aug 11 00:04:26 jks-laptop kernel: Initializing USB Mass Storage driver...
Aug 11 00:04:26 jks-laptop kernel: usb.c: registered new driver
usb-storage
Aug 11 00:04:26 jks-laptop kernel: scsi0 : SCSI emulation for USB Mass
Storage devices
Aug 11 00:04:26 jks-laptop kernel: USB Mass Storage support registered.

unplugging and replugging:

Aug 11 00:13:06 jks-laptop kernel: usb.c: USB disconnect on device
00:07.2-1 address 3
Aug 11 00:13:16 jks-laptop kernel: hub.c: new USB device 00:07.2-1,
assigned address 4
Aug 11 00:13:19 jks-laptop /etc/hotplug/usb.agent: Setup usb-storage
for USB product 3f0/107/200
Comment 15 Joseph Shraibman 2004-08-11 00:16:38 EDT
Nevermind, got the right version.
Comment 16 Joseph Shraibman 2004-08-11 00:24:42 EDT
Whoops.  Just realized I was using the latest fc 1 kernel.  I'm going
to test with the correct kernel now.
Comment 17 Joseph Shraibman 2004-08-11 00:39:57 EDT
Can't install the fc2 kernel on redhat 9.  I'm putting the status back
as WONTFIX.
Comment 18 Pete Zaitcev 2004-08-11 00:55:51 EDT
Well, duh. Of course you need the whole FC2 system.

I did run FC2 kernels on FC1, but it's a hell of a job. You'd need
new modutils, initscrips, and maybe other stuff, I forget now...
Pulling that on RHL9 is not likely to work.
Comment 19 Joseph Shraibman 2005-09-29 21:14:40 EDT
It works fine with fedora core 3

Note You need to log in before you can comment on or make changes to this bug.