Bug 92083 - CUPS startup error
Summary: CUPS startup error
Status: CLOSED DUPLICATE of bug 88291
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-printer   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-02 16:04 UTC by Ross Johnson
Modified: 2007-04-18 16:54 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:53:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ross Johnson 2003-06-02 16:04:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Starting cups: Traceback (most recent call last):
  File "/usr/sbin/printconf-backend", line 7, in ?
    import backend
  File "/usr/share/printconf/util/backend.py", line 762, in ?
    (ipaddr, broadcast) = grok_sysconfig_files (interfaces)
  File "/usr/share/printconf/util/backend.py", line 644, in grok_sysconfig_files
   network = "NETWORK=%s.%s.%s.%s\n" % quad[:4]
UnboundLocalError: local variable 'quad' referenced before assignment


Version-Release number of selected component (if applicable):
redhat-config-printer-0.6.47-1

How reproducible:
Sometimes

Steps to Reproduce:
1.service cups start
2.
3.
    

Additional info:

Perhaps something in my config has triggered the traceback.

Fixed (I think) by adding line at line 644
 
       if match:
>>>         quad = match.groups ()
            network = "NETWORK=%s.%s.%s.%s\n" % quad[:4]

Comment 1 Tim Waugh 2003-06-02 16:21:15 UTC
A fix is already in the works.

*** This bug has been marked as a duplicate of 88291 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:53:20 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.