Bug 92117 - Disabling Permissions Denorm Triggers causes data loading error
Disabling Permissions Denorm Triggers causes data loading error
Status: CLOSED WONTFIX
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity low
: ---
: ---
Assigned To: Archit Shah
Jon Orris
:
Depends On:
Blocks: 108447
  Show dependency treegraph
 
Reported: 2003-06-02 17:00 EDT by Bryan Che
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 10:38:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bryan Che 2003-06-02 17:00:25 EDT
In Oracle, I disabled the following triggers:

DISABLED tigger ACS_PERMISSIONS_IN_TR
DISABLED tigger ACS_PERMISSIONS_UP_TR
DISABLED tigger ACS_PERMISSIONS_DEL_TR

Then, when I tried to populate data, I got an exception:

003-06-02 16:52:53,416 [ main] FATAL initializer.Script - Fatal error loading
initialization script
com.arsdigita.persistence.PersistenceException:  (root cause:
com.arsdigita.persistence.proto.FlushException: all events not flushed for obj:
[com.arsdigita.cms.Cont\
entBundle:{id=2357}]
violations: [<pdata
[com.arsdigita.kernel.permissions.ObjectContext:{objectId=2357}].object>, <pdata
[com.arsdigita.kernel.permissions.ObjectContext:{objectId=2353}]\
.object>])
        at com.arsdigita.persistence.DataObjectImpl.save(Unknown Source)
        at com.arsdigita.domain.DomainObject.save(Unknown Source)
        at com.arsdigita.cms.populate.CreateArticle.makeContent(Unknown Source)
        at com.arsdigita.cms.populate.PopulateContent.populate(Unknown Source)
Comment 1 Richard Li 2003-06-03 10:03:37 EDT
Marking blocking for RC0 in case this is a symptom of some other deeper bug.
Comment 2 Jon Orris 2003-08-05 11:48:16 EDT
Deffered to Rickshaw and/or first dot release of Troika

Note You need to log in before you can comment on or make changes to this bug.