Bug 9212 - Problem with iso9660 file system on RH 6.1
Problem with iso9660 file system on RH 6.1
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
: 9600 9655 14955 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2000-02-08 05:17 EST by reinert.korsnes
Modified: 2008-05-01 11:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-12-13 21:33:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description reinert.korsnes 2000-02-08 05:17:10 EST
Problem with RedHat 6.1:

We got several cdrom from NASA (Sea Ice Concentrations from Nimbus-7

When we mount one of these cdroms via the command
"mount -t iso9660 /dev/cdrom /mnt/cdrom",
several files (file names) do not show up via "ls".

This bug seems not to be under RedHat 5.2.  Here
all file names seem to show up via "ls".

E-mail: Reinert.Korsnes@npolar.no
Comment 1 Riley H Williams 2000-02-09 13:50:59 EST
Can you do the following to identify the precice problems here please:

 1. Under RH 5.2:

        ls -flaR /cdrom > /tmp/cd-5.2

 2. Under RH 6.1:

        ls -flaR /cdrom > /tmp/cd-6.1

 3. After both have been done:

        diff -u /tmp/cd-5.2 /tmp/cd-6.1 > /tmp/cd.diff

When you've done so, post /tmp/cd.diff on here, and let's see what it shows up.
Comment 2 Riley H Williams 2000-02-09 13:51:59 EST
I am of course assuming that /cdrom is the mount point of the CD in question,
and also that it is mounted when you do the above...
Comment 3 Preston Brown 2000-02-16 10:22:59 EST
bill, this one seems very strange.  Is it possible that it is not a strict
iso9660 disk?
Comment 4 Bill Nottingham 2000-02-16 10:27:59 EST
Does it also occur if you do 'mount -t iso9660 -o norock,nojoliet <dev> <mount
Comment 5 ole-hes 2000-02-19 10:34:59 EST
I experience the same problem. When reading CDs with a large number of files
on RH60, RH61 and RH62, some files are lost. No error messages. With the vector
chart CDs from C-MAP containing some 14700 files, the problem is 100%
Comment 6 Cristian Gafton 2000-02-23 21:11:59 EST
*** Bug 9600 has been marked as a duplicate of this bug. ***
Comment 7 Cristian Gafton 2000-02-23 21:12:59 EST
*** Bug 9655 has been marked as a duplicate of this bug. ***
Comment 8 Doug Ledford 2000-02-23 23:44:59 EST
Are the same files lost each time or does the problem change from run to run?

If it's the exact same files each time, then likely the problem would be in the
filesystem code.  If the files change from run to run, then it could be
hardware.  If they do change from run to run, then I would like you to run the
memtest script that is on my web page http://people.redhat.com/dledford and let
us know the results of that test (it not only tests memory but it will catch
possible DMA corruptions you may be getting on your drive bus, which could be a
cause of problems with your CD, and it's perfectly possible for the upgrade from
5.2 to later versions to cause this due to differences in the IDE code in the
kernel or differences in SCSI drivers, depending on which type of CD you have).
Comment 9 Tim Waugh 2000-02-24 03:28:59 EST
I've had a similar problem to this for quite a long time, starting sometime
before 2.2.x.  I'm fairly convinced it's the CD-ROM drive, rather than the disks
or the kernel.  The symptom I get is this:

Sometimes, when using tab-completion to navigate the CD-ROM, a directory will
appear as a file.  That is, tab-completion puts a space after the name, and ls
-l doesn't show a 'd' where it should.  After a mount -oremount everything is
fine again.  This wouldn't happen every time, but reasonably often.

I've heard the same symptom (and the same fix) over the phone while talking
customers through installing RPMs.

This CD-ROM drive is quite old, but I've heard it happen with newer ones too.
Comment 10 Bernhard Rosenkraenzer 2000-02-24 04:43:59 EST
I've seen a similar problem a couple of times. It was related to autorun still
having mounted an old CD while the user had already inserted a new one.
Does this problem still occur if you turn off autorun?
Comment 11 Stephen Tweedie 2000-02-24 05:25:59 EST
This has been reported occassionally on linux-kernel too for some while,
but I've never been able to reproduce it.  I'll try building an iso of lots
of small files to try things on, but it would help if somebody could post
me a CD which exhibits the problem.
Comment 12 Stephen Tweedie 2000-02-25 10:44:59 EST
Plain Red Hat 6.1 kernel, new CD burnt with 45000 files in multiple directories.
No problem.  New CD burnt with 30000 files in a single directory.  No problem.

I can't reproduce this here --- a CD image demonstrating the bug would really
Comment 13 Graham Cole 2000-02-27 06:56:59 EST
I noticed that the MS Office 2000 Professional cd's will generate this error.
If you have trouble reproducing the error, try what i did in #9655 (duplicate)

I disagree that it's drive dependant, otherwise it would not show up when you
mount duplicate iso images over loopback.
Comment 14 Stephen Tweedie 2000-02-28 11:00:59 EST
I just tried the suggestion in #9566 (copying an iso, mounting both images and
recursive diffing the entire mount).  It worked fine with the ISOs I tried
it on.

An example ISO is still needed to progress this.  I don't have access to
the Microsoft disk referenced above.
Comment 15 Matthew Roth 2000-06-21 11:50:23 EDT
Glad to see I am not the only person with this problem.  I am running RH6.1 on a 
Compaq Deskpro EN Series, and I fairly consistently see this problem when 
tar'ing up Oracle DBMS software CD's.  Due to licensing issues I can't provide 
you a CD.  The problems seem to occur more frequently with CDs for Solaris, then 
AIX and HP-UX.
Comment 16 olex 2000-06-30 04:58:27 EDT
As I have said earlier, I can provide you with a vector chart CD which
consistently shows this error. The Quake III CD (Windows version), containing
far fewer files, still occasionally shows the error.

This error shows up in Red Hat 6.0, 6.1 and 6.2, but not in the earlier
5 series. The hardware configuration seems irrelevant - all my laptops and
tower systems shows the error, on both IDE and SCSI CDROM drives.
Comment 17 Alan Cox 2000-08-01 05:23:07 EDT
*** Bug 14955 has been marked as a duplicate of this bug. ***
Comment 18 Alan Cox 2000-08-01 05:24:35 EDT
2.2.17pre fixes one of the problems here. I dont know if it fixes all of them.

Note You need to log in before you can comment on or make changes to this bug.