Bug 92140 - gconf/configuration problems with rawhide rpm
Summary: gconf/configuration problems with rawhide rpm
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: GConf2   
(Show other bugs)
Version: 9
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-03 08:07 UTC by Need Real Name
Modified: 2007-04-18 16:54 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-04 21:06:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2003-06-03 08:07:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Linux 2.4.20-9 i686) Opera 7.11  
[en]

Description of problem:
I have been using evolution for a while, and upgrades from a version to another 
have always gone without problems, but this time a serious problem occured. When 
I start evolution, the configuration-tool asks for emailadress/ 
incoming/outcoming mail properties and so on, although this information was used 
by the previous release of evolution. When I'm almost finish with the 
configuration, the configuration tool crashes, so when I start evolution next 
time, it launches the configuration tool. It's stuck in a loop.

Here is the output:

$ evolution
file /home/oysteigy/evolution/vfolders.xml contains nothing to upgrade
xml file `/home/oysteigy/evolution/filters.xml' already upgraded
evolution-shell-Message: Evolution configuration upgraded to version: 1.3.1

(evolution:3596): e-utils-WARNING **: e_config_listener_set_bool: Failed to 
contact configuration server; some possible causes are that you need to enable 
TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. 
See http://www.gnome.org/projects/gconf/ for information. (Details -  1: IOR 
file '/home/oysteigy/.gconfd/lock/ior' not opened successfully, no gconfd 
located: No such file or directory 2: IOR file '/home/oysteigy/.gconfd/lock/ior' 
not opened successfully, no gconfd located: No such file or directory)

(evolution:3596): evolution-mail-importer-WARNING **: Broken line:


(evolution:3596): evolution-mail-importer-WARNING **: Broken line:


(evolution:3596): Bonobo-WARNING **: Failed to get 
'/desktop/gnome/interface/menubar_detachable': 'Failed to contact configuration 
server; some possible causes are that you need to enable TCP/IP networking for 
ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.
org/projects/gconf/ for information. (Details -  1: IOR file '/home/oysteigy/.
gconfd/lock/ior' not opened successfully, no gconfd located: No such file or 
directory 2: IOR file '/home/oysteigy/.gconfd/lock/ior' not opened successfully, 
no gconfd located: No such file or directory)'
warning: failed to load external entity 
"/home/oysteigy/evolution/config/storage-set-view-expanded:default"

gtkhtml-ERROR **: gconf error: Failed to contact configuration server; some 
possible causes are that you need to enable TCP/IP networking for ORBit, or you 
have stale NFS locks due to a system crash. See http://www.gnome.
org/projects/gconf/ for information. (Details -  1: IOR file '/home/oysteigy/.
gconfd/lock/ior' not opened successfully, no gconfd located: No such file or 
directory 2: IOR file '/home/oysteigy/.gconfd/lock/ior' not opened successfully, 
no gconfd located: No such file or directory)

aborting...


Version-Release number of selected component (if applicable):
evolution-1.3.92-1

How reproducible:
Always

Steps to Reproduce:
1.run evolution
2.
3.
    

Additional info:

I have tried to make a /home/oysteigy/.gconfd/lock/ior file, but it didnt work 
either. I'm using apt-get with ftp.uninett.no as archive. Here is my 
/etc/apt/sources.list: 

rpm ftp://ftp.uninett.no/pub/linux/apt redhat/rawhide/en/i386/redhat os
rpm-src ftp://ftp.uninett.no/pub/linux/apt redhat/rawhide/en/i386/redhat os

rpm ftp://ftp.uninett.no/pub/linux/apt redhat/9/en/i386/redhat freshrpms
rpm-src ftp://ftp.uninett.no/pub/linux/apt redhat/9/en/i386/redhat freshrpms

Comment 1 Havoc Pennington 2003-06-03 15:01:00 UTC
Run gconf-sanity-check-2; any output?

Comment 2 Havoc Pennington 2003-06-03 15:01:53 UTC
Also try running "gconfd-2" from the command line and see if it crashes or 
prints anything, and check syslog for gconf-related messages

Comment 3 Need Real Name 2003-06-04 10:55:05 UTC
I have neither gconfd-2, nor gconf-sanity-check-2, but I have gconfd-1 and 
gconf-sanity-check-1. 

$ gconf-sanity-check-1
Please contact your system administrator to resolve the following problem:
Failed to get a file lock: Failed to lock '/home/oysteigy/.gconfd/lock/ior': 
probably another process has the lock, or your operating system has NFS file 
locking misconfigured, or a hard NFS client crash caused a stale lock (Resource 
temporarily unavailable) - run gconf-sanity-check-1 for possible diagnosis, see 
http://www.gnome.org/projects/gconf/ for more information

I have not NFS mounted my homedir, it is on a regular ext3 partition on a local 
hardisk.

$ lsof | grep lock 
gconfd-1  2916   oysteigy    6wW  REG        3,3      265    190605 
/home/oysteigy/.gconfd/lock/0t1054721830ut351883u500                             
       p2916r1298960846k3221220092 (deleted)
gconfd-1  2916   oysteigy    7wW  REG        3,3      265    190608 
/home/oysteigy/.gconf/%gconf-xml-backend.lock/1t1054                             
       721830ut405734u500p2916r921870765k3221219708 (deleted)

running gconfd-1 gives me no kind of output.

The messages in /var/log/messages is similar to those from gconf-sanity-check-1








Comment 4 Havoc Pennington 2003-06-04 15:37:54 UTC
-2 versions are in /usr/libexec

Do you have an NFS home directory? If so removing ~/.gconf*/*lock/*
will probably fix things, it would be interesting to know if that
helps.

Comment 5 Need Real Name 2003-06-04 21:06:29 UTC
No, I do not have a NFS homedir, as I have already stated. But your tip worked
anyway, I  removed my .gconfd dir, and suddenly everything worked. Thanks.


Note You need to log in before you can comment on or make changes to this bug.