Bug 92169 - GCC: internal compiler error in ix86_compute_frame_size
Summary: GCC: internal compiler error in ix86_compute_frame_size
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i686 Linux
high
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-03 15:36 UTC by Jonathan Stowe
Modified: 2007-03-27 04:04 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-03 23:31:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File that causes the problem. Note that the comment does indicate the problem is a know one. (5.55 KB, text/plain)
2003-06-03 15:38 UTC, Jonathan Stowe
no flags Details

Description Jonathan Stowe 2003-06-03 15:36:08 UTC
Description of problem:

While compiling part of mono gcc fails with:

libtest.c: In function `mono_test_empty_struct':
libtest.c:267: Internal compiler error in ix86_compute_frame_size, at
config/i386/i386.c:1875

   
Version-Release number of selected component (if applicable):

2.96

How reproducible:

  gcc -c libtest.c  

libtest.c attached.


   


Steps to Reproduce:
1. As above
2.
3.
    
Actual results:

[gellyfish@orpheus tests]$ gcc -c libtest.c
libtest.c: In function `test_lpwstr_marshal':
libtest.c:10: warning: assignment makes pointer from integer without a cast
libtest.c: In function `mono_test_empty_struct':
libtest.c:267: Internal compiler error in ix86_compute_frame_size, at
config/i386/i386.c:1875
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.



Expected results:

   Successful compilation of the file.

Additional info:

Comment 1 Jonathan Stowe 2003-06-03 15:38:37 UTC
Created attachment 92114 [details]
File that causes the problem.  Note that the comment does indicate the problem is a know one.

Comment 2 Richard Henderson 2004-10-03 23:31:10 UTC
Fixed in gcc-3.2.3-20.


Note You need to log in before you can comment on or make changes to this bug.