Bug 92201 - nForce2 IDE support broken in kernel-2.4.20-13.9
nForce2 IDE support broken in kernel-2.4.20-13.9
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-03 15:50 EDT by Aran Cox
Modified: 2007-04-18 12:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 12:36:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aran Cox 2003-06-03 15:50:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
Under kernel-2.4.20-8, dmesg shows this:
Uniform Multi-Platform E-IDE driver Revision: 7.00beta-2.4
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
NFORCE2: IDE controller at PCI slot 00:09.0
NFORCE2: chipset revision 162
NFORCE2: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:DMA, hdd:DMA
hda: IC35L040AVER07-0, ATA DISK drive
hdb: SAMSUNG DVD-ROM SD-612, ATAPI CD/DVD-ROM drive
blk: queue c03be900, I/O limit 4095Mb (mask 0xffffffff)
hdc: IC35L120AVVA07-0, ATA DISK drive
blk: queue c03bed60, I/O limit 4095Mb (mask 0xffffffff)
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: host protected area => 1
hda: 80418240 sectors (41174 MB) w/1916KiB Cache, CHS=5005/255/63, UDMA(33)
hdc: host protected area => 1
hdc: 241254720 sectors (123522 MB) w/1863KiB Cache, CHS=239340/16/63, UDMA(33)

IDE support seems to work fine with quite fast tiobench numbers, etc.

Under kernel-2.4.20-13.9, dmesg shows this:
NFORCE2: IDE controller at PCI slot 00:09.0
NFORCE2: chipset revision 162
NFORCE2: not 100% native mode: will probe irqs later
AMD_IDE: Bios didn't set cable bits corectly. Enabling workaround.
AMD_IDE: Bios didn't set cable bits corectly. Enabling workaround.
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
AMD_IDE: PCI device 10de:0065 (nVidia Corporation) (rev a2) UDMA100 controller
on pci00:09.0
    ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:DMA, hdd:DMA
hda: IC35L040AVER07-0, ATA DISK drive
hdb: SAMSUNG DVD-ROM SD-612, ATAPI CD/DVD-ROM drive
blk: queue c03c58e0, I/O limit 4095Mb (mask 0xffffffff)
hdc: IC35L120AVVA07-0, ATA DISK drive
blk: queue c03c5d44, I/O limit 4095Mb (mask 0xffffffff)
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: attached ide-disk driver.
hda: host protected area => 1
hda: 80418240 sectors (41174 MB) w/1916KiB Cache, CHS=5005/255/63, UDMA(100)
hdc: attached ide-disk driver.
hdc: host protected area => 1
hdc: 241254720 sectors (123522 MB) w/1863KiB Cache, CHS=239340/16/63, UDMA(100)

Under 2.4.20-19.9, I get horrible tiobench numbers and it's clear I'm not
running at full speed.  (I assume I'm using some PIO transfer mode?)




Version-Release number of selected component (if applicable):
kernel-2.4.20-13.9

How reproducible:
Always

Steps to Reproduce:
1.  Boot up under 2.4.20-19.9 
2.  Run some benchmarks, disk IO crawls

    

Actual Results:  Diso I/O is slow as hell.

Expected Results:  Disk I/O should be pretty snappy with these drives and IDE
controller.

Additional info:
Comment 1 Alan Cox 2003-06-05 11:25:01 EDT
The trace shows UDMA100 for both cases. What does hdparm say ?
Comment 2 Aran Cox 2003-06-05 12:36:59 EDT
I'm exceedingly embarrased to say that I cannot reproduce the slow down I saw
when using 2.4.20-13.9 over 2.4.20-8... I just ran tiobench on both kernels and
got very comparable numbers on both kernels.  If anything, 2.4.20-13.9 is faster!

I'm going to mark this bug as invalid, and if I can reliably re-produce it in
the future I'll re-open it or open a new bug.

Regards,
Aran
Comment 3 Alan Cox 2003-06-05 14:04:26 EDT
Thanks for reporting it

Note You need to log in before you can comment on or make changes to this bug.