Bug 922036 - computer slow after resume from suspension
Summary: computer slow after resume from suspension
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 18
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-15 12:47 UTC by Federico
Modified: 2014-02-05 19:59 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-05 19:59:26 UTC
Type: Bug


Attachments (Terms of Use)

Description Federico 2013-03-15 12:47:09 UTC
Description of problem:

My laptop becomes very slow after resume from suspend.
I have a fresh (2 months) Fedora 18 installation with the default gnome 3.
My laptop is a dell Latitude e6520, with a discrete graphic card which uses the nvidia optimus technology, and an integrated intel graphic card.

The problem arises both if I disable the discrete card (i.e. only intel one) and if a I use only the discrete card (i.e. nvidia drivers).

If I resume from suspend, the computer is extremely slow, and each operation takes a long while it is completed. Also, in nautilus there are issues with the graphics.

However, I am not sure it is a gnome bug, since if I completely kill down the graphical session (init 3) and resume (init 5), nothing change.

Also, I tried to reload several system services, but nothing helps.

The only solution is a reboot, but it is very impractical for who is often traveling in trains...

Please, help me.

Version-Release number of selected component (if applicable):

Fedora 18, default software.

Steps to Reproduce:
1. Take down the lid
2. Wait for suspension
3. Open lid, and try to work.
  
Actual results:

Computer very, slow.
The suspicious thing is that the HD led indicator highlights a very slow activity. When I log in after a power on, the light is on actually continuously for 1 minute, while the desktop is loaded.

After a resume, even if I log out and back in, the HD light makes some blinks, but is never "continuously on".

Expected results:

Computer with the same performance as before.

Additional info:

Comment 1 Andrei Gherzan 2013-10-25 06:45:44 UTC
Have exactly the same annoying issue on my Fedora 18.

Comment 2 Federico 2013-10-25 07:12:22 UTC
Actually I updated my machine previously with F19, and now I am running F20 alpha.

The behavior did not changed at all.

The computer is very slow, unresponsive when resumed from suspend to ram.

In the meantime I tried to debug by myself (having not received help!)

After resume, a small increase in performance that renders the machine usable, even if far from the performance of a clean boot, is to reset the cpu governor.

For example I created a small script switching for a couple of seconds to performance governor and then back to the ondemand one.
Actually I found that after resume the ondemand governor wasn't able to switch again frequencies, leaving the processor stick to very low values.

I tried to unload/reload all other services ona by one, from the graphical shell to the various hw driver (graphics, audio, etc.)
This does not solve the issue at all.

I'd  like to underline that my machine is a pro wirkstation, quad-core i7 with 8 GB of ram. This only to say that with similar characteristics the slow down caused by this issue is very evident. I mean it should be a serious misbehavior of some part of the system since it is not a very small, quite imperciptible change!

I hope this could help someone else.

Federico

Comment 3 Fedora End Of Life 2013-12-21 12:10:33 UTC
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 4 Fedora End Of Life 2014-02-05 19:59:26 UTC
Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.