Bug 922263 - [abrt] policycoreutils-devel-2.1.13-55.fc18: __init__.py:22:swig_import_helper:ImportError: /usr/lib64/python2.7/site-packages/selinux/_selinux.so: undefined symbol: selinux_binary_policy_path_min_max
Summary: [abrt] policycoreutils-devel-2.1.13-55.fc18: __init__.py:22:swig_import_helpe...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: policycoreutils
Version: 18
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:3b032de68b5279feaae3f324190...
: 917201 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-15 21:23 UTC by Lukas Zachar
Modified: 2013-05-14 16:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-03 04:51:35 UTC


Attachments (Terms of Use)
File: backtrace (1.18 KB, text/plain)
2013-03-15 21:23 UTC, Lukas Zachar
no flags Details
File: core_backtrace (536 bytes, text/plain)
2013-03-15 21:23 UTC, Lukas Zachar
no flags Details
File: dso_list (85 bytes, text/plain)
2013-03-15 21:23 UTC, Lukas Zachar
no flags Details
File: environ (999 bytes, text/plain)
2013-03-15 21:23 UTC, Lukas Zachar
no flags Details

Description Lukas Zachar 2013-03-15 21:23:17 UTC
Description of problem:
Happend while updating from latest f18 using
yum --releasever=19 distro-sync --nogpgcheck --disableplugin=presto

Version-Release number of selected component:
policycoreutils-devel-2.1.13-55.fc18

Additional info:
cmdline:        /usr/bin/python -Es /usr/bin/audit2allow
executable:     /usr/bin/audit2allow
kernel:         3.8.2-206.fc18.x86_64
uid:            1000

Truncated backtrace:
__init__.py:22:swig_import_helper:ImportError: /usr/lib64/python2.7/site-packages/selinux/_selinux.so: undefined symbol: selinux_binary_policy_path_min_max

Traceback (most recent call last):
  File "/usr/bin/audit2allow", line 23, in <module>
    import sepolgen.audit as audit
  File "/usr/lib64/python2.7/site-packages/sepolgen/audit.py", line 20, in <module>
    import refpolicy
  File "/usr/lib64/python2.7/site-packages/sepolgen/refpolicy.py", line 22, in <module>
    import selinux
  File "/usr/lib64/python2.7/site-packages/selinux/__init__.py", line 26, in <module>
    _selinux = swig_import_helper()
  File "/usr/lib64/python2.7/site-packages/selinux/__init__.py", line 22, in swig_import_helper
    _mod = imp.load_module('_selinux', fp, pathname, description)
ImportError: /usr/lib64/python2.7/site-packages/selinux/_selinux.so: undefined symbol: selinux_binary_policy_path_min_max

Local variables in innermost frame:
fp: <closed file '/usr/lib64/python2.7/site-packages/selinux/_selinux.so', mode 'rb' at 0x2742030>
imp: <module 'imp' (built-in)>
dirname: <function dirname at 0x7f4f9bc13500>
pathname: '/usr/lib64/python2.7/site-packages/selinux/_selinux.so'
description: ('.so', 'rb', 3)

Comment 1 Lukas Zachar 2013-03-15 21:23:21 UTC
Created attachment 710898 [details]
File: backtrace

Comment 2 Lukas Zachar 2013-03-15 21:23:23 UTC
Created attachment 710899 [details]
File: core_backtrace

Comment 3 Lukas Zachar 2013-03-15 21:23:26 UTC
Created attachment 710900 [details]
File: dso_list

Comment 4 Lukas Zachar 2013-03-15 21:23:28 UTC
Created attachment 710901 [details]
File: environ

Comment 5 Daniel Walsh 2013-03-20 01:07:27 UTC
Please update to the latest policycoreutils.

Comment 6 Fedora Update System 2013-03-28 12:14:04 UTC
policycoreutils-2.1.13-59.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/policycoreutils-2.1.13-59.fc18

Comment 7 Fedora Update System 2013-03-29 01:35:39 UTC
Package policycoreutils-2.1.13-59.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing policycoreutils-2.1.13-59.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-4555/policycoreutils-2.1.13-59.fc18
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2013-04-03 04:51:37 UTC
policycoreutils-2.1.13-59.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Nils Philippsen 2013-05-14 16:22:53 UTC
*** Bug 917201 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.