Bug 92232 - RFE: add space or enter as keynav of Monitor Configuration
RFE: add space or enter as keynav of Monitor Configuration
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda-help (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-03 20:07 EDT by Alexandre Oliva
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-11 13:02:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2003-06-03 20:07:44 EDT
Trying to do a graphical install without using the mouse is not entirely
obvious.  In particular, the convention that - and + are to be used to show the
monitors of a certain monitor vendor was not obvious to me.  Even if this is a
standard key binding, we might still make sense to get space and/or enter when a
vendor is selected to toggle display/hide of its components?
Comment 1 Bill Nottingham 2003-07-24 18:43:15 EDT
It's using the standard GTK keynav bindings, AFAIK.
Comment 2 Alexandre Oliva 2003-07-26 21:50:35 EDT
If we can expect someone who tries to install without using the mouse to be
familiar with the standard GTK keynav bindings, we're probably fine.  I just
thought we could make it a bit more tolerant to users' (and my) ignorance of
such standards.
Comment 3 Jeremy Katz 2003-10-16 13:44:54 EDT
This is normal treeview usage -- users doing keynav are somewhat expected to
know the standard GTK+ keynav usage.
Comment 4 Alexandre Oliva 2003-10-17 12:26:48 EDT
I have to disagree.  The help screen mentions other key bindings that are to be
used for keyboard navigation that are far more obvious, so these are clearly
missing.
Comment 5 Sandra Moore 2004-08-03 18:24:51 EDT
Help text has been updated to add additional keyboard-based navigation
strategies. 

The Welcome screen for the installation program will read as follows
for  future releases of RHEL.

  Welcome to Red Hat Enterprise Linux

 During this installation, you can use your mouse or keyboard to  
 navigate through the various screens.

 The Tab key allows you to move around the screen, the Up and Down 
 arrow keys to scroll through lists, + and - keys expand lists, while 
 Space and Enter selects or removes from selection a highlighted item.

 Use the Next and Back buttons to progress through these screens.  
 Click Next to save the information and proceed to the next screen;  
 click Back to move to the previous screen.

 To minimize this help screen, click on the Hide Help button.

 The release notes provide an overview of features that may not have  
 been available for documentation. To view the release notes, click   
 the Release Notes button and a new window appears. Click Close to 
 close the release notes and return to the installation program.

 You can cancel this installation any time before the About to Install 
 screen. When you click Next on About to Install, package installation 
 begins and data is written to your hard drive. To cancel before this 
 screen, you can safely reboot your system (using the reset button, or 
 Ctrl-Alt-Del). 

Closing bug as updates will appear soon.
Comment 6 Alexandre Oliva 2004-09-15 17:19:27 EDT
I'm looking at an FC3test2-ish installer, and it looks much better,
indeed.  I'd suggest a few additional changes, though.  Make it +/- to
expand/collapse lists (- doesn't expand, it collapses).  Also, you
might want to note that Alt-letter is equivalent to clicking on
buttons that have the corresponding letter underlined.
Comment 7 Sandra Moore 2004-09-16 13:07:25 EDT
Thanks for the additional feedback. The updated text will read as follows:

During this installation, you can use your mouse or keyboard to
navigate through the various screens.

The Tab key allows you to move around the screen, the Up and Down
arrow keys to scroll through lists, + and - keys expand and collapse
lists, while Space and Enter selects or removes from selection a
highlighted item. You can also use the Alt-X key command combination
as a way of clicking on buttons or making other screen selections,
where X is replaced with any underlined letter appearing within that
screen.

Use the Next and Back buttons to progress through these screens. Click
Next to save the information and proceed to the next screen; click
Back to move to the previous screen.

To minimize this help screen, click on the Hide Help button.

The release notes provide an overview of features that may not have
been available for documentation. To view the release notes, click the
Release Notes button and a new window appears. Click Close to close
the release notes and return to the installation program.

You can cancel this installation any time before the About to Install
screen. When you click Next on About to Install, package installation
begins and data is written to your hard drive. To cancel before this
screen, you can safely reboot your system (using the reset button, or
Ctrl-Alt-Del).

This should cover it. :-) 

I'm reassinging to katzj for this update to be rolled into both
installers. 

Comment 8 Alexandre Oliva 2004-10-02 15:57:07 EDT
Looks like the latest change (about Alt-X keys) didn't make it to
FC3-re1001.0.  Oh well...
Comment 9 Jeremy Katz 2004-10-04 09:23:19 EDT
That's just because I hadn't beaten anaconda-help into building yet by
then.

Note You need to log in before you can comment on or make changes to this bug.