Bug 922648 - gnome-abrt doesn't recover from errors caused by accessing of invalid problems
Summary: gnome-abrt doesn't recover from errors caused by accessing of invalid problems
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-abrt
Version: 17
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Filak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:8725957207523bd65b9536084d9...
Depends On: 920417
Blocks: 922647
TreeView+ depends on / blocked
 
Reported: 2013-03-18 08:30 UTC by Jakub Filak
Modified: 2016-12-01 00:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 920417
Environment:
Last Closed: 2013-04-10 01:33:46 UTC


Attachments (Terms of Use)

Description Jakub Filak 2013-03-18 08:30:15 UTC
+++ This bug was initially created as a clone of Bug #920417 +++

Version-Release number of selected component:
gnome-abrt-0.2.8-1.fc19

Additional info:
cmdline:        python /usr/bin/gnome-abrt
executable:     /usr/bin/gnome-abrt
kernel:         3.9.0-0.rc1.git0.4.fc19.i686.PAE
uid:            1000

Truncated backtrace:
dbus_problems.py:130:get_items:InvalidProblem: '/var/tmp/abrt/ccpp-2013-03-12-11:51:25-6163' is not a valid problem directory

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/gnome_abrt/directory_problems.py", line 59, in check
    def check(self, *args):
  File "/usr/lib/python2.7/site-packages/gnome_abrt/controller.py", line 61, in <lambda>
    signal.signal(signal.SIGCHLD, lambda signum, frame: self._handle_signal(signum))
  File "/usr/lib/python2.7/site-packages/gnome_abrt/controller.py", line 37, in _handle_signal
    self.source.refresh()
  File "/usr/lib/python2.7/site-packages/gnome_abrt/problems.py", line 266, in refresh
    self.notify()
  File "/usr/lib/python2.7/site-packages/gnome_abrt/problems.py", line 255, in notify
    super(MultipleSources, self).notify(change_type, problem)
  File "/usr/lib/python2.7/site-packages/gnome_abrt/problems.py", line 60, in notify
    observer.changed(self, change_type, problem)
  File "/usr/lib/python2.7/site-packages/gnome_abrt/views.py", line 120, in changed
    self.wnd._reload_problems(source)
  File "/usr/lib/python2.7/site-packages/gnome_abrt/views.py", line 237, in _reload_problems
    self._add_problem_to_storage(p)
  File "/usr/lib/python2.7/site-packages/gnome_abrt/views.py", line 213, in _add_problem_to_storage
    self.ls_problems.append(problem_to_storage_values(problem))
  File "/usr/lib/python2.7/site-packages/gnome_abrt/views.py", line 84, in problem_to_storage_values
    return ["{0!s}\n{1!s}".format(doN(app.name, _("N/A")), doN(problem['type'], "")),
  File "/usr/lib/python2.7/site-packages/gnome_abrt/problems.py", line 123, in __getitem__
    loaded = self.__loaditems__(item)
  File "/usr/lib/python2.7/site-packages/gnome_abrt/problems.py", line 104, in __loaditems__
    items = self.source.get_items(self.problem_id, *args)
  File "/usr/lib/python2.7/site-packages/gnome_abrt/dbus_problems.py", line 130, in get_items
    raise errors.InvalidProblem(e.message)
InvalidProblem: '/var/tmp/abrt/ccpp-2013-03-12-11:51:25-6163' is not a valid problem directory

Local variables in innermost frame:
info: {}
self: <gnome_abrt.dbus_problems.DBusProblemSource object at 0x8633fec>
args: ('type',)
e: DBusException("'/var/tmp/abrt/ccpp-2013-03-12-11:51:25-6163' is not a valid problem directory",)
problem_id: '/var/tmp/abrt/ccpp-2013-03-12-11:51:25-6163'

--- Additional comment from Christopher Meng on 2013-03-12 05:28:00 CET ---

Created attachment 708761 [details]
File: backtrace

--- Additional comment from Christopher Meng on 2013-03-12 05:28:02 CET ---

Created attachment 708762 [details]
File: core_backtrace

--- Additional comment from Christopher Meng on 2013-03-12 05:28:05 CET ---

Created attachment 708763 [details]
File: environ

--- Additional comment from Jakub Filak on 2013-03-12 08:39:07 CET ---

Thank you for taking the time to report this bug. I fixed it yesterday.

Upstream commit caf50bcaeb1b755e3a84f508efebbca3f0bcb2fd

--- Additional comment from Jakub Filak on 2013-03-18 08:27:36 CET ---

*** Bug 922580 has been marked as a duplicate of this bug. ***

Comment 1 Fedora Update System 2013-03-19 08:59:05 UTC
gnome-abrt-0.2.9-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gnome-abrt-0.2.9-1.fc17

Comment 2 Fedora Update System 2013-03-20 21:32:19 UTC
Package gnome-abrt-0.2.9-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-abrt-0.2.9-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-4046/gnome-abrt-0.2.9-1.fc17
then log in and leave karma (feedback).

Comment 3 Fedora Update System 2013-03-29 10:16:04 UTC
gnome-abrt-0.2.10-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gnome-abrt-0.2.10-2.fc17

Comment 4 Fedora Update System 2013-04-10 01:33:48 UTC
gnome-abrt-0.2.10-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.