Bug 92312 - RPM seg fault (core dump)
RPM seg fault (core dump)
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.0
alpha Linux
high Severity high
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-04 15:36 EDT by ddionne
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-19 09:30:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ddionne 2003-06-04 15:36:26 EDT
Description of problem:
I updated from rpm 4.0-4.3 which was the original 7.0 version to the updated 
version 4.0.4-7x and now i cant install, upgrade, or erase rpms.  I have done 
a --rebuilddb and that didnt help.
I was in the process of building a new kernel from kernel.org and following 
the prerequisits for the new kernel.
I have the following:
glibc-2.3.2-5
make-3.79.1-5
binutils-2.13.90.0.18-9
util-linux-2.10s-12
modutils-2.4.2-5
rpm-4.0.4-7x
rpm-devel-4.0.4-7x
rpm-python-4.0.4-7x
rpm-build-4.0.4-7x
rpm-perl-4.0.4-7x

And i am currently running the stock vmlinux-2.2.19-7.0.1 kernel



Version-Release number of selected component (if applicable):rpm-4.0.4-7x


How reproducible:Every Time


Steps to Reproduce:
1.rpm -Uvh *any package*
2.rpm -ivh *any package*
3.rpm -e *any package    

Actual results:
root@alpha random]# rpm -Uvh e2fsprogs-1.32-6.alpha.rpm 
Preparing...                ########################################### [100%]
Segmentation fault (core dumped)
[root@alpha random]# rpm -ivh jfsutils-1.0.17-6.alpha.rpm 
Preparing...                ########################################### [100%]
Segmentation fault (core dumped)
[root@alpha random]# rpm -e wu-ftpd
Segmentation fault (core dumped)
[root@alpha random]#

Expected results:
Should have ugraded e2fsprogs, installed jfsutils,and removed wu-ftpd.

Additional info:HELP!
Comment 1 Jeff Johnson 2003-06-05 07:33:20 EDT
Hmmm, first thing to control for is LDAP
passwords. Make sure you are running nscd by doing
    /sbin/service nscd start

If that doesn't fix, give me a pointer (i.e. URL, attachments
won't work) to a tarball of your database
    cd /var/lib
    tar czvf /tmp/rpmdb-92313.tar.gz rpm
and I'll take a look.
Comment 2 ddionne 2003-06-05 13:18:53 EDT
Hey, nscd was already running but i restarted it and that didnt help.
If you have ftp access you can get that tarball at:
ftp://guest:rpmissue@dionne.net/home/guest/rpmdb-92313.tar.gz.
Comment 3 ddionne 2003-06-10 14:22:07 EDT
I still get the seg fault.
Comment 4 ddionne 2003-06-10 16:38:08 EDT
You said:

OK. Next is to make sure that nscd is running. As root

/sbin/service nscd restart

Could you also see if anything in rpm works? Try
rpm --version
rpm -qa
rpm -q rpm
rpm -Va --nofiles
rpm -V rpm pam

nscd was already started and but i restarted it anyway.  I still get the seg 
fault BUT all of the above commands worked:

[root@alpha random]# rpm -q rpm
rpm-4.0.4-7x
[root@alpha random]# rpm -Va --nofiles
[root@alpha random]# rpm --version
RPM version 4.0.4
[root@alpha random]# rpm -qa
gdk-pixbuf-devel-0.8.0-5
enscript-1.6.1-11
setserial-2.17-2
ed-0.2-17
giftrans-1.12.2-7
.
.
.
[root@alpha random]# rpm -V rpm pam
.....UG. c /var/lib/rpm/Basenames
.....UG. c /var/lib/rpm/Conflictname
.....UG. c /var/lib/rpm/Dirnames
.....UG. c /var/lib/rpm/Filemd5s
.....UG. c /var/lib/rpm/Group
.....UG. c /var/lib/rpm/Installtid
.....UG. c /var/lib/rpm/Name
.....UG. c /var/lib/rpm/Packages
.....UG. c /var/lib/rpm/Providename
.....UG. c /var/lib/rpm/Provideversion
.....UG. c /var/lib/rpm/Requirename
.....UG. c /var/lib/rpm/Requireversion
.....UG. c /var/lib/rpm/Sha1header
.....UG. c /var/lib/rpm/Sigmd5
.....UG. c /var/lib/rpm/Triggername
.....UG. c /var/lib/rpm/__db.001
.....UG. c /var/lib/rpm/__db.002
S.5....T c /etc/pam.d/system-auth
[root@alpha random]# 
Comment 5 Jeff Johnson 2003-06-19 09:30:28 EDT
Yes user/group reverts to root on /var/lib/rpm/* after --rebuilddb.

You might look at what has changed in system-auth.

AFAICT, you have a mismatch between rpm and glibc/pam somehow.

You might try upgrading and/or changing glibc/pam. Yes you
will have to do this manually using rpm2cpio to extract package
contents. And, since glibc and pam are involved, you want to
be very, very careful, as a loss of a shared library may render
your machine unbootable. Try to find a competent sysadmin, or ask
for help on say, redhat-list@redhat.com.

The path of least resistance might very well be to go back to earlier,
known good, version of rpm, again using rpm2cpio

Note You need to log in before you can comment on or make changes to this bug.