Bug 92339 - kernel upgrades break USB
kernel upgrades break USB
Status: CLOSED DUPLICATE of bug 92338
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-05 06:07 EDT by Mimo Zus
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:53:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mimo Zus 2003-06-05 06:07:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

Description of problem:
I am running redhat 9 SMP on a dual PIII 733Mhz Abit VP6,
current kernel is 2.4.20-9smp.

Attempting to upgrade the kernel to either 2.4.20-13.9, or 2.4.20-18.9
breaks USB.

--/var/log/messages----2.4.20-18.9smp----------------------------
kernel: usb.c: registered new driver usbdevfs
kernel: usb.c: registered new driver hub
kernel: usb-uhci.c: $Revision: 1.275 $ time 07:05:27 May 29 2003
kernel: usb-uhci.c: High bandwidth mode enabled
kernel: usb-uhci.c: USB UHCI at I/O 0xa000, IRQ 19
kernel: usb-uhci.c: Detected 2 ports
kernel: usb.c: new USB bus registered, assigned bus number 1
kernel: usb-uhci.c: USB UHCI at I/O 0xa400, IRQ 19
kernel: usb-uhci.c: Detected 2 ports
kernel: usb.c: new USB bus registered, assigned bus number 2
kernel: usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
kernel: usb.c: registered new driver hiddev
kernel: usb.c: registered new driver hid
kernel: usb_control/bulk_msg: timeout
kernel: usb.c: USB device not accepting new address=2 (error=-110)
kernel: usb_control/bulk_msg: timeout
kernel: usb.c: USB device not accepting new address=3 (error=-110)
----------------------------------------------------

-----/var/log/messages 2.4.20-9smp ---------------------
      1   kernel: usb.c: registered new driver usbdevfs
      2   kernel: usb.c: registered new driver hub
      3   kernel: usb-uhci.c: $Revision: 1.275 $ time 13:38:06 Apr  2 2003
      4   kernel: usb-uhci.c: High bandwidth mode enabled
      5   kernel: usb-uhci.c: USB UHCI at I/O 0xa000, IRQ 19
      6   kernel: usb-uhci.c: Detected 2 ports
      7   kernel: usb.c: new USB bus registered, assigned bus number 1
      8   kernel: hub.c: USB hub found
      9   kernel: hub.c: 2 ports detected
     10   kernel: usb-uhci.c: USB UHCI at I/O 0xa400, IRQ 19
     11   kernel: usb-uhci.c: Detected 2 ports
     12   kernel: usb.c: new USB bus registered, assigned bus number 2
     13   kernel: hub.c: USB hub found
     14   kernel: hub.c: 2 ports detected
     15   kernel: usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
     16   kernel: usb.c: registered new driver hiddev
     17   kernel: usb.c: registered new driver hid
     18   kernel: hid-core.c: v1.8.1 Andreas Gal, Vojtech Pavlik <vojtech@suse.cz>
     19   kernel: hid-core.c: USB HID support drivers
     20   kernel: mice: PS/2 mouse device common for all mice
     21   kernel: hub.c: new USB device 00:07.2-2, assigned address 2
     22   kernel: input0: USB HID v1.10 Mouse [Logitech USB-PS/2 Optical Mouse]
on usb1:2.0
---------------------------------------------------------





Version-Release number of selected component (if applicable):
kernel-2.4.20-13.9, or 18.9

How reproducible:
Always

Steps to Reproduce:
1.Boot vmlinuz-2.4.20-13.9smp
2.Boot vmlinuz-2.4.20-18.9smp
3.
    

Actual Results:  USB optical mouse non-responsive, USB errors appear in logs

Expected Results:  All kernel upgrades have been transparent through 2.4.20-9smp

Additional info:

Abit VP6 mobo, dual PIII 733mhz
Comment 1 Mimo Zus 2003-06-05 06:31:26 EDT
Didn't mean to create this report.  Already submitted #92338.
Comment 2 Arjan van de Ven 2003-06-05 06:32:30 EDT

*** This bug has been marked as a duplicate of 92338 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:53:27 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.