Bug 92346 - Keyboard layout should be asked before root password in /.unconfigured part
Keyboard layout should be asked before root password in /.unconfigured part
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-05 08:30 EDT by Panu Matilainen
Modified: 2014-03-16 22:36 EDT (History)
1 user (show)

See Also:
Fixed In Version: 7,.25-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 11:15:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Ask keymap first in unconfigured mode (518 bytes, patch)
2003-06-05 08:32 EDT, Panu Matilainen
no flags Details | Diff

  None (edit)
Description Panu Matilainen 2003-06-05 08:30:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
In "unconfigured" mode rc.sysinit first asks for root password and later asks
for keyboard layout. This can cause problems with some special characters vs
different keyboard layouts.

Fix is truly trivial, patch to follow..

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install a system using some "standard/common" kickstart file which does
"touch /.unconfigured" at %post
2. Enter new root password 
3. Change keyboard layout to something "exotic"
    

Actual Results:  It can be a bit difficult to login since you have to guess the
original keyboard layout and figure where the relevant characters are on your
own keymap.

Expected Results:  It should first ask the keyboard layout so you can enter the
root password in your native keymap.

Additional info:

This is an ages old "bug" present in all versions I know of.
Comment 1 Panu Matilainen 2003-06-05 08:32:03 EDT
Created attachment 92160 [details]
Ask keymap first in unconfigured mode
Comment 2 Bill Nottingham 2003-06-05 11:15:16 EDT
Added to cvs, will be in 7.25-1.

Note You need to log in before you can comment on or make changes to this bug.