Bug 9238 - Vim (not vi) doesn't handle control chars properly
Summary: Vim (not vi) doesn't handle control chars properly
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-core   
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-08 19:23 UTC by Steve Wills
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-11 10:19:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steve Wills 2000-02-08 19:23:04 UTC
To demonstrate, start vim, press F1 for help. It no worky.

Comment 1 Bernhard Rosenkraenzer 2000-02-09 12:34:59 UTC
Works for me currently (dist-6.2 tree as of 2000/02/09 12:15 GMT).

Comment 2 Steve Wills 2000-02-09 19:05:59 UTC
What package version are you refering to? I'm using vim-*-5.6-5 from the beta.
The newest package I see in rawhide is 5.6-4. I tried 5.6-4 and still had the
problem.

Comment 3 Bernhard Rosenkraenzer 2000-02-09 19:33:59 UTC
I'm using 5.6-5 along with the other required updates - ncurses 5.0-9,
termcap-10.2.7-5 and, if you're running it in a konsole window in KDE,
kdebase-1.1.2-27.

Comment 4 Steve Wills 2000-02-09 20:10:59 UTC
I'm using ncurses 5.0-9, but I can't find the termcap-10.2.7-5. The latest I can
find is termcap-10.2.7-4. Where is the newer version? Also, have you tried this
in a gnome-terminal? Thats where I'm seeing the problem.

Comment 5 Bernhard Rosenkraenzer 2000-02-10 09:55:59 UTC
Just checked it - it's a problem with gnome-terminal, not vim.
The recent termcap changes aren't handled by gnome-terminal yet.

Comment 6 Preston Brown 2000-02-11 02:33:59 UTC
bero -- you going to take care of this one?

Comment 7 Bernhard Rosenkraenzer 2000-02-11 10:19:59 UTC
Sure - I've actually fixed it yesterday (new gnome-libs, the problem was in the
zvt widget, not gnome-terminal itself).


Note You need to log in before you can comment on or make changes to this bug.