Bug 92384 - kernel oops in stress test
kernel oops in stress test
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Larry Woodman
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-05 13:53 EDT by Eric Schwartz
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 18:55:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Schwartz 2003-06-05 13:53:17 EDT
Description of problem:

This is a log snippet that shows a kernel oops when running our internal system
stress test:

pid 2306 Starting: /busy2/bin/swaptest 4... (count: 45939)
Summation up to 30000 = 4.5001500000e+08
pid 2309 Starting: /busy2/bin/swaptest 1... (count: 45727)
Summation up to 30000 = 4.5001500000e+08
pid 2308 Starting: /busy2/bin/swaptest 2... (count: 43477)
Summation up to 30000 = 4.5001500000e+08
pid 2307 Starting: /busy2/bin/swaptest 3... (count: 46632)
Summation up to 30000 = 4.5001500000e+08
pid 2224 Starting: /busy2/bin/swaptest 5... (count: 46498)
Summation up to 30000 = 4.5001500000e+08
pid 2306 Starting: /busy2/bin/swaptest 4... (count: 45940)
Summation up to 30000 = 4.5001500000e+08
pid 2309 Starting: /busy2/bin/swaptest 1... (count: 45728)
Summation up to 30000 = 4.5001500000e+08

Unable to handle kernel NULL pointer dereferencecmp[9933]: Oops 4294967296
--> [unresolved] <--

Pid: 9933, comm:                  cmp
psr : 0000101008026018 ifs : 8000000000000b1b ip  : [<0000000000000000>]    Not
tainted
unat: 0000000000000000 pfs : 0000000000000b1b rsc : 0000000000000003
rnat: e0000040c4877e10 bsps: e0000040c4870000 pr  : fffffffffffe5a29
ldrs: 0000000000000000 ccv : 0000000100000000 fpsr: 165554535251504f
b0  : e0000040c4877cc0 b6  : a000000000031c20 b7  : e00000000440d930
f6  : 1003e0000000000000000 f7  : 1003e0000000000000000
f8  : 100018000000000000000 f9  : 10002a000000000000000
r1  : e000000004cf1610 r2  : 0000000000000000 r3  : e0000000048a0ed5
r8  : 0000000000000000 r9  : 0000000000000000 r10 : 0034363333363936
r11 : 0000000000000000 r12 : e0000040c4877e50 r13 : e0000040c4870000
r14 : 0000000000000000 r15 : 0000000000000000 r16 : e00000042b366230
r17 : e00000042b366ca0 r18 : e00000042b366ca0 r19 : fffffffffffffeff
r20 : e000000004afd318 r21 : e000000004afd328 r22 : 000000000000ffff
r23 : 0000000000000000 r24 : 3736353433323130 r25 : 6665646362613938
r26 : 6e6d6c6b6a696867 r27 : 767574737271706f r28 : 6e6d6c007a797877
r29 : 767574737271706f r30 : 3736353433323130 r31 : 0000000000000000

Call Trace: [<e0000000044148b0>] sp=0xe0000040c4877a40 bsp=0xe0000040c4877ed0
decoded to show_stack [kernel] 0x50
 pid 2308 Starting: /busy2/bin/swaptest 2... (count: 43478)
Summation up to 30000 = 4.5001500000<0>Kernel panic: not continuing
e+08
pid 2224 Starting: /busy2/bin/swaptest 5... (count: 46499)
Summation up tIn interrupt handler - not syncing
o 30000 = 4.5001500000e+08
pid 2306 Starting: /busy2/bin/swaptest 4... (count:  45941)
Summation up to 30000 = 4.5001500000e+08
pid 2309 Starting: /busy2/bin/swaptest 1... (count: 45729)
Summation up to 30000 = 4.5001500000e+08

Version-Release number of selected component (if applicable):
2.4.18-e.31smp

How reproducible:
not very

Steps to Reproduce:
1. run busy stress test for 24Hrs (should be reproducable with cerberus)
2.
3.
    
Actual results:
kernel oopses


Expected results:
kernel doesn't oops

Additional info:
Comment 1 Larry Woodman 2003-06-05 14:49:57 EDT
I havent been able to get my system to fail under a memory load.
Can you attach the program that caused this to happen or help me
to get a reproducable case?

Thanks, Larry Woodman
Comment 2 Ernie Petrides 2005-10-05 18:55:57 EDT
Closing due to lack of response.

Note You need to log in before you can comment on or make changes to this bug.