Bug 924234 - Don't hide needinfo on closed bugs
Don't hide needinfo on closed bugs
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
4.2
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Simon Green
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-21 08:10 EDT by Einav Cohen
Modified: 2016-01-28 16:56 EST (History)
4 users (show)

See Also:
Fixed In Version: 4.4.0009
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-03 20:46:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Einav Cohen 2013-03-21 08:10:25 EDT
Description of problem:
when setting a 'needinfo?'/'addl. needinfo?' flag on a CLOSED BZ, it is being automatically cleared (by design). 
Please don't do that - sometimes a discussion on a CLOSED bug is needed, especially when considering to re-open it.

Version-Release number of selected component (if applicable):
version 4.2.5-8.1

How reproducible:
100%

Steps to Reproduce:
1. set 'needinfo?'/'addl. needinfo?' on a CLOSED BZ
2.
3.
  
Actual results:
'needinfo?'/'addl. needinfo?' is automatically cleared

Expected results:
'needinfo?'/'addl. needinfo?' remains until someone checks the "I am providing the requested information for this bug" (just like for a non-CLOSED BZ)

Additional info:
Comment 1 Simon Green 2013-04-15 18:29:42 EDT
I'm also going to take this chance to remove our needinfo code and replace it with the code that BMO (but not upstream) uses. There code is 100% extension base, while ours is intermingled with the core code.

http://bzr.mozilla.org/bmo/4.2/files/head:/extensions/Needinfo/
Comment 2 wangjing 2013-04-23 23:43:41 EDT
simon, hi~
this feature worksforme on QE test env version 4.4.rc2-2. 
has it been fixed on 4.4-2?
thanks!
Comment 3 Simon Green 2013-04-23 23:48:22 EDT
(In reply to comment #2)
> has it been fixed on 4.4-2?

No.
Comment 5 Simon Green 2013-10-03 20:46:22 EDT
This change is now live. If there are any issues, do not reopen this bug.
Instead, you should create a new bug and reference this bug.

  -- simon

Note You need to log in before you can comment on or make changes to this bug.