Bug 92456 - 4.07 sysstat - bad memory reporting for large memory machines
Summary: 4.07 sysstat - bad memory reporting for large memory machines
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: sysstat (Show other bugs)
(Show other bugs)
Version: 2.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-06 14:09 UTC by erikj
Modified: 2007-11-30 22:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-12 07:03:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is a diff of my changes to solve the problem in systat 4.07 (4.72 KB, patch)
2003-06-07 02:54 UTC, erikj
no flags Details | Diff
This is a more human-readable diff format for browsing. (7.28 KB, text/plain)
2003-06-07 02:56 UTC, erikj
no flags Details

Description erikj 2003-06-06 14:09:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0)

Description of problem:
I realize that AS 2.1 contains sysstat 4.01.  However, this version
is a bit broken for ia64.  In SGI's ProPack overlay, we install
sysstat 4.07.

I'm entering this bug as I understand the next AS will have 4.07.

There is a bug in the way SADC reads /proc/meminfo that affects
machines with 100g of memory or more -- it truncates the memory
usage string to 8 characters.

I contacted the Author to let him know a fix he may want would be
coming.  I also wanted to be sure to file a Redhat bug.

I have fixed the problem and my testing shows it seems to be working.
I'll post a diff as soon as my code fix is peer reviewed internally.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Log in to a machine with more than 100g of memory and systat 4.07
2. Run a commadn like "sar -r 1 10"
3. Notice that the memory info reported is truncated.  Compare to
   /proc/meminfo.
    

Additional info:

As I said, I will have a code diff for this after my fix is peer
reviewed internally.  Expect an additional add soon (a day or two).

Comment 1 erikj 2003-06-07 02:54:39 UTC
Created attachment 92223 [details]
This is a diff of my changes to solve the problem in systat 4.07

This is a regular rdiff of my changes to the 4.07 sysstat to fix this bug. 
I'll also post a more human-readable
zdiff in a moment.

Comment 2 erikj 2003-06-07 02:56:57 UTC
Created attachment 92224 [details]
This is a more human-readable diff format for browsing.

Comment 3 Ivana Varekova 2005-05-11 15:09:19 UTC
Thank you for your notice. 
The current RHEL2 sysstat version is 5.0.5-14.21as and this version contains
similar changes. So this bug is fixed.
Ivana Varekova


Note You need to log in before you can comment on or make changes to this bug.