Bug 927299 - Horizon doesn't display proper error when Quantum quota exceeded when adding subnets
Horizon doesn't display proper error when Quantum quota exceeded when adding ...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: snapshot1
: 3.0
Assigned To: Julie Pichon
Ofer Blaut
: Triaged
Depends On: 950565
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-25 11:30 EDT by Lon Hohberger
Modified: 2016-04-26 23:56 EDT (History)
10 users (show)

See Also:
Fixed In Version: python-django-horizon-2013.1.1-1.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 891302
Environment:
Last Closed: 2013-05-29 11:06:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1070899 None None None Never

  None (edit)
Description Lon Hohberger 2013-03-25 11:30:23 EDT
+++ This bug was initially created as a clone of Bug #891302 +++

Description of problem:
Horizon doesn't display proper error when Quantum quote exceeded 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.configure quantum to use quotes
( http://docs.openstack.org/folsom/openstack-network/admin/content/cfg_quotas_common.html )

2. configure amount of network to  exceeded  quote via horizon 
3. check error output 
  
Actual results:

Error by  horizon : Failed to create 

Expected results:

Error by CLI : "Quota exceeded for resources: ['network'] "

Additional info:

--- Additional comment from Ofer Blaut on 2013-03-20 06:00:51 EDT ---

Issue still occurs in python-django-horizon-2012.2.3-8.el6ost.noarch


creating 10 subnets on the same network :

Error: Failed to create subnet 30.1.7.0/24, nothing about Quota

--- Additional comment from Julie Pichon on 2013-03-20 07:05:50 EDT ---

Thanks for the additional information Ofer. The initial bug report described an issue when creating new networks, which the patch focused on fixing. I agree the error handling should be more consistent though. Fixing this also for subnets can probably be done later in async in a separate bug, or if that's not acceptable I guess we can move this one out. I don't think it's a blocker. (For the record it's fixed in Grizzly.)

--- Additional comment from Lon Hohberger on 2013-03-25 11:22:32 EDT ---

If the original issue is resolved, let's split the additional bug off.
Comment 3 Ofer Blaut 2013-05-28 04:48:02 EDT
tested 

The error is now ok



×

Error: Failed to create subnet "2.2.12.0/24" for network "None": Quota exceeded for resources: ['subnet']
Comment 5 errata-xmlrpc 2013-05-29 11:06:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0878.html

Note You need to log in before you can comment on or make changes to this bug.